Beacon Naming Dialog Bug


#1

I’ve found (and confirmed) that if I move too far away from a beacon to interacti with it while I’m in the process of naming it,when I return to the beacon and attempt to rename it I can’t interact properly with the dialog to finish renaming the beacon.

The first time this happened I tried several things until i crashed (just submitted crash logs too) and when it happened to another avatar a few minutes later I just restarted without waiting for anything else to crash.


#2

I can see that there’s one crash dump, so I can add this to the bug database. Are you able to explain the other things you were doing that may have caused the crash to occur?


#3

I was attempting to name a beacon while swimming. That’s how I got into the situation.

After the first time I tried to interact with the menus, or something to get the dialog working again but after a couple of attempts it still couldn’t be edited.

At that point I was also unable to return to the sanctum, or quit the game using the menu.

I tried to use the “`” key to unbind the mouse/keyboard form the game and then re-opened the menu but it didn’t work. I may have hit escape and enter a couple times to see if chat was working. I hit the "X"and the game closed so I wasn’t sure it was a crash (windows never asked me to force close the app) until I logged back in and got offered the option to submit the crash dump.

I went to the beacon and tried to name it more quickly, made a typo again,and sank out of range. After the same thing happened I just restarted and did the beacon admin from a nearby roof.


#4

That looks like the grave accent / back tick symbol. When you said you used it to unbind the mouse / keyboard from the game and then reopened the menu, what did you mean by this? Were you trying to assign the key to some of the mouse and keyboard functions for example?


#5

Yes sorry it’s the one over the tilde on my US keyboard layout. Left of the 1.

I wasn’t trying to change any bindings.This key releases all keyboard/mouse input in my configuration.

I just went into the control settings to find the name of the setting but now I don’t see it as listed/adjustable. When the button is pressed, the mouse and keyboard input are unbound from boundless and I’m able to work with other windows or programs without having to create a modal situation for my avatar.

I frequently use it to get the keyboard working again when I have problems from stuff like trying to open a trade window while I have chat on.

There are a couple of situations where the mouse cursor can be left active after opening/closing a mix of dialogs and so you don’t have camera control. Pressing this key and then clicking back into the game often addresses that.


#6

To clarify specifically, when I was unable to enter text or control the cursor in the name beacon dialog, I pressed “backtick” and clicked on my windows desktop.

I then clicked back into the game (mouse clicking in the boundless window, and re-binding the mouse/keyboard input to boundless), re-opened the menu, and was still unable to enter or delete any text in the dialog.

Sorry if that’s not all correct technical use of the word “binding”, but it appears to be the behavior.