Blocks are... missing

Hi all

I gifted this game to my nephews as we think it already looks great and has loads of potential! Problem is, when they load it in Steam, all the blocks are missing… as in invisible. They can see grass, candles, leafs etc, just no blocks. Have tried reducing all settings to minimum to no effect. See screenshot of what they see. http://i.imgur.com/SgX3nfc.png
Any help is greatly received.

What operating system and graphics card are they using and are the graphics card drivers up to date?

hi Ardos

They are Windows 8 and have a “radeon hd 7670m” graphics card with directx11. will check about the drivers being upto date.

thanks for quick reply.

I don’t know about this game/that card specifically but quite often games have issues with mobile versions of graphics cards. I hope an update of drivers will fix it. Making sure Windows is up to date as well could possibly help.

Ah, thanks Ardos, I will get them to update everything they can. Much appreciated!

Ok - that’s weird. Guessing a driver issue or failed shader compilation. (So it’ll be something else…)

  1. Most importantly - really make sure the graphics drivers are up to date. Go here: http://support.amd.com/en-us/download

  2. Can you please share a gist of the game log?

Thanks James, will get them to follow the link [fingers crossed]. Will have to walk my nephews through the game log upload. Will hopefully post later! Thanks for the help.

Hi James, updated the drivers and no luck unfortunately. Managed [i think] to get the log on gist so here goes: https://gist.github.com/anonymous/f4e2aaaf25e404be225d.js

Edit:

Link is: https://gist.github.com/anonymous/f4e2aaaf25e404be225d

Ok - so the issue is:

  1. Some of the shaders are failing to compile.

  2. The render uses more sophisticated shaders for the voxel world and they’re not able to render. Giving you the visual result you’re seeing.

Question:

  1. What graphics device / GPU is in this machine?

  2. What graphics drivers do you have installed?

Options:

  1. Tweaking the graphics setting + a driver update may help. (I appreciate you reported that the drivers are already up-to-date.)

  2. We’re working on a new graphics driver for DX11. When this is deployed it should hopefully resolve the shader issue. This updated driver will not be ready to try for a month or so.

Sorry that I don’t have an instant fix for you at the moment.

Thanks for the quick reply James. they are offline now but will get that info tomorrow. They have messed around with the setting and updated the drivers this morning so it could well be the DX11 thing [like i have any idea what i’m talking about]. Can’t wait for them to wander round this world of yours, playing this was the first time i have stopped to watch a sunset since Red Dead Redemption :slight_smile:

1 Like

Hi James, just so you know my nephews have loaded they game up on their laptop and it now works like a charm! so whatever arcane wizardry you did, it worked :slight_smile:

2 Likes

Err, I wish we could claim some great fix here - but I can’t. We may have fixed something that inadvertently fixed your issue. If so, praise the Oort!

The DX11 graphics driver is just around the corner - we’ll hopefully have a beta available next week for everyone to try.

Thanks for sticking with the game and reporting the issues so patiently - it’s appreciated.

EDIT:

Actually this is probably a little unfair on the team. They’ve fixed many many issues in the recent releases. Hopefully these changes (and any potential driver updates) have also resolved your issue.