Cant update Boundless with Steam

Well I’m facing the Problem that Boundless got updates and in steam it shows me the update will come in 5 minutes, and this 5 minutes won’t change so if i wait 5 and try to update then it says content is locked and if i check the update page afterwards it shows me update is coming in 5 minutes. So anyways i can’t start the game using steam as well, which doesn’t really matter since i can start it using my explorer.

I would be happy if you guys can help me

U tried to reinstal it, or even Steam?

1 Like

As suggested try uninstallnig [right click on in it
Steam-> Delete Local Content] and reinstall would be the first thing to try.
It does require Steam running to play the game.

If you had used one of the beta versions go back to the default one [right click->Properties->Betas->None - opt out of all beta programs].

1 Like

The Beta thingy doesn’t change anything i will just reinstall it and tell you afterwards if the Problem is solved or not
Thanks for the help

Well it works now and looks much better than yesterday when i tried it with my local files. Looks awesome thanks for your help @michaelb and @Kawwak :kissing_heart:

1 Like