Connecting (Error: 17) -> FIXED

Getting error 17 when logging in to Boundless. Confirmed this is happening on my account (UK) and one other (US).

Not sure if it is Steam related or not.

Edit: Confirmed cases on PS as well as Steam, so not a Steam issue.

1 Like

Same error over here for me …
… unable to log in

Can confirm you are not the only one. Seems the authentication servers are in trouble?
Others in: [COMPLETE] Brief Downtime at 0930 UTC
One of them is confirming on PS4 as well, so should not be Steam related.


Same error, I switched characters to craft stuff, cannot log back in, I’m on steam

Same Problem Here


yup. same here

Let’s see if we can summon a @james as no one is able to login at all now.

1 Like

I was in game but the closed it and can’t go log back in now

Same issue for me!

Selbe Problem alle member von Bavaria aktuell

Same issue for me!

This is it. The end times.

Just joking, but imagine if this was the way things ended. :sweat_smile:

1 Like

This is a good thread for hopping in with the same error. Rebooted the PC, Updated Steam, relaunched Boundless.


Sad face. Starting work in 11 min, will check back in at breaktime.

PS. I even forcefully logged out and back in to steam to be sure… :wink:

Okay last update before breaktime… I did UNINSTALL and REINSTALL
same error…

Here’s hoping it’s fixed so I can do stuff at lunch :wink:

ANNNNND… I’m in :slight_smile: Yay!

same here (UK)
made the foolish mistake of trying to switch toons

maybe one of the reasons why james has been reluctant to start events etc recently because of the possible time having to be spent trouble-shooting afterwards :man_shrugging:

Just coming back to boundless after a 3 month break and get this error, its like the game doesnt want me to comeback lol

1 Like

same here :confused:

Same problem for me (ps4)

I’ve been playing since 5am up until now to take a nap. I’ve had no problems what so ever. AFTER I log out to jump in bed. I decided to look at the forums and see this thread. So I get back up to log in and see. And yeap sure enough error 17. I’m not liking this at all. Hopefully after my nap it will all be fixed. Fingers crossed

Same issue, on Steam. I really had the itch to play today too lol