(Fixed)Can not connect to universe server

Tried to log in and got Connection to Universe server timed out. Ran a file check in Steam and one file failed. i did a reinstall checked the files again and all good. launched the game and same thing again.

i got it working

My friend still can’t get on he has the same issue

Does he use the PriceHarvester ?

He’s on PlayStation

My issue was with host files on PC . Not having knowledge with ps4 problems best I can say is try to reinstall or reset the router . Sorry :confused:

He’s tried that three times but thanks for trying

What is the error msg that is appearing on screen?

The same one up at the top

Well, since everyone else can make a connection to that discovery server it looks like something is wrong with your internet, your local network, router, etc., etc.

The server works otherwise no one would be able to log in…

It’s not the internet. It’s PS4 because there was a topic a few days ago about it and everyone who had this issue or similar was on PS4. I just found the topic last night after I found this one. And I personally had the same issue and we have different internet’s and are in different states

That was a bug in the game which has been solved recently.

Same thing tho: if everyone else on PS4 can log in normally then it’s not the game…