Illegal protocol message


#1

So I left the hunt last night by returning to the sanctum. Afk’ed for a bit and then when I tried to get back on the portal had closed and said unable to connect to world.
So I used the other portal to open one to my home beacon, same message.
I left it 2 hours and tried again with the same result.

Just logged in now and got to the sanctum fine but still can’t open either portal… It’s just saying ILLEGAL PROTOCOL MESSAGE and the same Unable to connect to world notification.

I’m on PS4… What’s going on? :frowning: should be hunting right now!

Edit: I’ve tried different worlds and tried beacons and friends and my alt is also stuck

Edit 2: one of my alts is able to open a portal home but it is unplayable and kicks me back to the illegal protocol message after a minute or so

@vdragon @james :pray:


#2

I’ve had that a few times before. I think usually I have to restart my ps4. Tho it could just be pure coincidence and it may go away on its own while I’m doing that without me knowing lol.

But hope you can get back in soon.


#3

I’ll give it a go, why not. Though my problem started last night so the ps has been restarted since then.
Thank you though I’ll try anything right now lol


#4

Ahh yea I almost never turn the power off to my ps4. It’s always rest mode. I notice if I do that for too long things some times load slower(menus,ps store,etc). So i blame that on a lot of my problems i might get. Tho a lot of them might not be that lol.


#5

Oh my. I’ve not actually powered it down :eyes: :eyes: it always rests.
holds breath and restarts ps

If this is literally a case of turning it off and back on again I’m going to be delightfully embarrassed :laughing:

Edit: Okay so my pride has taken a bit of a hit but I’m back in :rofl: :rofl: thank you…


#6

Okay so I was back in, world became unstable and literally disappeared around me.

Back in the sanctum again unable to open either portal :rofl: what is this madness


#7

Maybe we need to turn the worlds off and back on.


#8

Please do, i may go insane stuck here…


#9

What planet are you on? Do other planets work?


#10

You could try a rebuild database as well if you haven’t done that in a while. I recommend doing that once a month at least. Gets rid of all the random :poop: like getting rid of cookies(etc) on a pc


#11

My home world is Arie, I’ve tried Arie Dzassak and Circ with the same results.
Tried my 2 alts, one is stuck, the other can open Arie but it’s unstable and kicks me after a minute.


#12

Well I’d say try two things. Rebuild the database on your ps4. Doesn’t take long. Couple of minutes. And the other would be to reset your modem.


#13

Thanks will do


#14

If those fail to work I’d say start screaming for dev help lol. Really wouldn’t know what else to try after those.


#15

Ah still no joy :frowning: and my gaming time is almost up for today. Hopefully it will right itself by tomorrow… Or the sound of the portals trying to open is going to drive my character to insanity


#16

Have you restarted your router/modem?


#17

Not yet, I did the rebuild database. Will try resetting it tomorrow if I still can’t get in


#18

Looking at the server logs it looks like it’s a connection/routing problem between you and the servers, typically when we see connection issues this bad it’s just some part of the internet that’s overloaded/badly configured and it gets resolved within a few hours. So hopefully it’ll be fixed by the next day, if it persists we can try and run some tests (if you have a pc available) to see if we can see where the issue is.

What’s actually happening is that you’re connecting to the server (this we allow to happen regardless of how long that connection takes).
When we get this new connnection we reserve you a slot on the server (max sure it can’t become full while you complete your connection)
The server then sends a handshake message back to the client over this connection and waits for the client to complete the handshake.
We allow several seconds for this to complete but if it doesn’t we treat the client as non responsive, free up the server slot and close (kick) the connection. At the moment this closure is happening with the generic illegal protocol message you’re seeing, I’m logging a bug to get this replaced with a more descriptive message.
So each time you connect it’s then simply taking too long to complete the handshake so you get disconnected, note that even if we waited and let you connect the game would be completely unplayable with messages taking as long as this handshake is doing.

As mentioned I imagine it’ll resolve itself, if not we’d need to try and identify the routing issue, in theory you could then report that to your isp but many isps seem to not have good interfaces to report and get these sort of things fixed. Unless it’s stopping 50% of their userbase from streaming netflix they don’t care so much about occasional longer distance routing issues.


#19

Thanks for the detailed reply I appreciate it!
Hopefully it will resolve itself today then.
Unfortunately I don’t have access to a PC but will let you know if it persists this afternoon


#20

Hey tricky worth checking your ISP website for outages or calling them to test your router remotely