Invisible character and blurry text (Please help!)

So when i play the game my character is invisible and the game text is blurry, i already updates my drivers and i already reinstalled the game a few times. :frowning:

That sounds a lot like https://forum.oortonline.com/t/invisible-characters/2774

Do you also have an Intel HD gpu?

Can you copy your log file to a gist https://gist.github.com/ - the log file should be in
%LOCALAPPDATA%\Turbulenz\Oort Online\oortonline_log.txt

I have Intel HD Graphics Family. And yeah i’m having the same problem.

Here it is: https://gist.github.com/Julianros1998/aa7e82d57ba9d7ffdc2e

The logs showing
Intel® HD Graphics Family (Driver Ver: ‘8.15.10.2418’, Date: '6-10-2011

but it looks like there are much newer drivers on Intels site, either 2014 or 2015.

Intel seem to have a utility to help update here

or if you known select from https://downloadcenter.intel.com

I did that yesterday xD.

This is realy weird because i downloaded the update utility yesterday and installed all of the latest stuff…

I guess you rebooted since?

Did you choose manually or use the Intel utility?

It could be they have not actually altered the low level driver for some time.

i rebooted manually, i didn’t see a button for it. Also should i close everything i was doing when its downloading? Thank you very much for you help btw.

A reboot would be sufficient - no need to close things when it downloads.

Do you know which version of the Intel HD it is?
[Open ‘Device Manager’, type it in the Start Menu search, and expand the Display Adapters section]

We’ll check the drivers on the machines we have to see if we can reproduce this.

I just noticed i might have doen something wrong with the update utility yesterday, so i’m gonna try that now. I will let you know if it worked.

Some where it should say one of the HD 3000, HD 4000 etc versions. Maybe on the computer case. If its a branded PC googling the exact version of the may say.

It just says Intel HD Graphics Family, It still doesn’t work.

What make and version is your PC/laptop?

We will investigate our end to see if we can reproduce the issue.

Hello. Can you also send us a screenshot of the problem (the blurry text)?

Thanks

We tested on the HD we have and it seems ok.

Looking up your CPU shows it has an Intel HD 3000 gpu. For Windows 7 64 bit version Intels site show this link as the latest https://downloadcenter.intel.com/download/24971/Intel-HD-Graphics-Driver-for-Windows-7-8-64-bit and that it should be reporting “This driver package contains version 15.28.24.64.4229 (9.17.10.4229) for Windows 7/8.” which is newer than the ‘8.15.10.2418’ being logged out.

Okey, thank you i will try this.

It didn’t work.

Humph. Did it actually upgrade the driver, i.e. the log file now says 9.17 or does it still say 8.15?

Its says: 9.17.10.4229

Its says:

9.17.10.4229