Lamps not giving any light

I don’t know if this should go in the “suggestions” or in the “support” category, I guess I’ll just leave it here.
As the title says, lamps no longer provide any light (at least from my experience). Torches still illuminate everything around, both when I carry them in arms and when I place them somewhere. However, this is not the case with lamps.

Do I miss something here? Maybe the lamps now need to be “ignited” to light everything around them properly? I tried combining a lamp and a torch in the crafting menu but nothing happened.

Here’s a screenshot of the issue: http://puu.sh/gYhUb/dd58fc26a9.jpg
The block in the middle of the screen is a lamp. It doesn’t provide any light, as I said before.

Here’s another screenshot with a torch in my hand: http://puu.sh/gYiet/8a0ff46d8e.jpg
As you can see, the lamp doesn’t even come close in terms of lighting.

Try the bloom setting off, that ‘fixed it’ for me

Looks like a lighting bug. Where is this in the game?

Can we have the World and it’s coordinates?

Well, you can check it on Cshrime at -1829.51, 20.90, 0.41, for example. There barely enough light to see properly even though I’ve placed 2 lamps every 5 blocks. Screenshot: http://puu.sh/h4nDe/1e440356a0.jpg

I have bloom disabled, lamps still barely give any light at all unless you stack a lot of them together.

There are a couple of issues here:

  1. How bright do the lamps themselves look? I think you currently have some of the advanced lighting features turned off. If you enable these then the lamps themselves will look brighter.

  2. How much ambient environmental light do the lamps generate? I think that we need to tweak these values. We need to find a balance where 1 lamp gives off sufficient light, and 100 lamps (which is extremely common in the game) also gives off a sane amount of light. These also need to be balanced against the HDR lighting effect we have in the game (where the player’s eyes can adjust to the lighting.)

So I don’t think there is a particular bug here - rather than we need to balance the lighting values a little.

Could you check to see if you have Per-Pixel (and Advanced Per-Pixel) Lighting turned on or off?

Both of these were turned off. When I turned them on, the lamps themselves became much brighter: http://puu.sh/h5i5l/c335c5140b.jpg
However, the overall amount of light they actually give didn’t change as far as I could see.

I never said this was a bug, I just pointed out that a single lamp barely gives any light :slight_smile:

1 Like