My controller locked up twice this morning (PS4)


#1

Twice this morning I set down my controller to get something from another room. Both times the controls were locked up when I got back. I had to close the game and restart.

Note it was ONLY the game controls. The PS button worked fine.

Everything else around me seemed to be running as normal.


#2

It happened to me once, i put the controller away to use the keyboard and when I picked it up again it didnt work, ps button worked so I restarted the game, no issue afterwards.


#3

Try doing a hard shut down on it. Hold the middle PS4 button and the share button (left side, right of d pad). For 6ish seconds.


#4

If you ever have issues re connecting to bluetooth after that just plug in to your PS4 and unblock it , hit the PS4 button and should be good.


#5

I was plugged in. Everything worked fine outside of Boundless.


#6

I think pressing the ~ key will lock out the controller for some reason. Until you reset.


#7

Just to reiterate, the controller worked fine outside of Boundless. The PS button also worked just fine. The problem was 100% within Boundless, specifically.

The lockout happened from me going idle, not from a button I pressed.


#8

■■■■ the hard shut down is ps4 button + L2 (hold 5+ sec)

bluetooth activation is ps4 button + share(hold 5+ sec)

SOrry


#9

I just use my ps4 controller on PC… prefer it


#10

@Biv do you have a keyboard plugged into the PS4? just since if you don’t we can eliminate that from the possible things that may cause this.
You mention you were plugged in, do you mean you have configured the PS4 to communicate with the controller over USB? ( Settings > Devices > Controllers > Communication Method) or just that it was connected and charging? (Note you can only use the USB comms method on the newer ZCT2 controllers)


#11

I have an issue at times where my controller disconnects when I’m playing Boundless, I thought maybe it was just my controllers, etc.

But since I have been playing other games more recently it has never happened apart from in Boundless.

Not quite the same, but perhaps related?


#12

Does it just switch off randomly while you’re actually playing and providing input, i.e. not an idle power off?


#13

Yep, can be in the middle of mining and suddenly disconnect, citizen continues to perform what ever action I was doing until I can reconnect the controller.


#14

@Biv

Uh, just realised I might of hijacked your post, apologies.

If @Blake says these things are not related, I will create a separate post.


#15

I’m watching the thread now so I should be able to cover both problems you and @Biv are having.
For you @fidach next time it happens as soon as you reconnect the controller can you go into the Boundless in game support menu and hit the submit game log button, that’ll send us the game log and it may reveal something to explain why the controller is randomly disconnecting. I suspect I may have to find a way to let you crash the game after it happens so that I can get the lower level system logs that we get with crash dumps but for now I can at least check the game log.
Let me know if you submit one so I can go and find it.


#16

OK, will do!


#17
  1. Yes, keyboard was plugged in. Just for additional info, i didn’t use it at all that morning.

  2. No, it was not connected to communicate through the wire, that i know of. I’ve never set it up to do that, at any rate. Just for charging because PS4 controllers have battery life of 2 minutes.

  3. I haven’t encountered it since. I’ll let you know if it happens again and try to get a vid…not sure if that would be any help to you, though.


#18

No worries.


#19

Submitted a log after a controller disconnect.


#20

@blake
Just submitted report after another disconnect.