Private planet still not spawned [resolved]

Hi guys,

Yesterday morning I submitted a form to create a 6km planet that it didn’t spawn even now.
if I try the code in redeem panel it sais the status is valid but can’t see the code in the Redeemed Keys and also can’t click the button to redeem.

Any chance a dev could have a look over it?

given that this post is public I won’t post any private info to not dox myself :smiley:
from the form, the "What is your USER name? " was submitted for this username I write this post.

1 Like

in case James is reachable, I sent him the key code in a DM.

Forgot to mention that I tried to submit the form again this morning. Google sheets seems to allow it so thought it might have not went through the first time. Unfortunately I have no visibility in the process.

has it been 24 hours since form submitted the first time?
FAQ: Sovereign and Creative World - General / FAQ - Boundless Community (
If so then good idea to pm james again. He can take a little while to get back to you but, in my experience, has always responded to sovereign creation problems.

Indeed, had issues in the past and @james replied pretty fast to sovereign world issues.
It will be 24h from the form submission in about 20 min. I’ll wait and see if it appears until evening, if not, well, still won’t be able to do anything than write here a comment. :slight_smile:

1 Like

Seems like they’re taking a bit longer last few days… just had one that was over 24 hrs out pop in the last couple hours, so keep checking in. (I’m rolling a bunch right now trying to get the perfect area for a project… I’m probably bogging down their system, haha).


That is good to know that it can take more than 24h tks for telling that @bucfanpaka <3

1 Like

:frowning: even now still nothing. donno what to think, really hope there are a lot of people that bought planets and I’m in a big queue, otherwise it might be an issue with the registration, maybe I misspelled something, or god knows what.

Damn yeah, and I remember you were telling us about it in-game about 18 hours ago, too, and then you had already been waiting roughly 6 hours…

yap. donno what is happening and there’s no visibility of any kind on the process.
Hopefully a dev will notice the post.



Yeah, if you misspell the username or character name it will delay it, I’ve done this at least once and I think more. :flushed:

Also now imagining James coming in and giving the sovereign machine a good kick and knocking them all loose…


Sooo… probably not the best move, but got another planet :))
This time I made sure I fill it in correctly, will see tomorrow morning if I get any, if not, well it’s not the first 80 euro I lose.


I filled out the wrong info on my planet last month and it took James a few to get to it, but he handled it. Glad to see you got another… maybe that’s a good thing now you twice the fun!

1 Like

well, it;'s not over yet :smiley: will see in the morning if I get the 2nd one, but yea, will have 2 options to chose from


Both appeared last night, so I guess there was a very big queue. :slight_smile:
Screenshot_1 Screenshot_2


This is rly off topic but just noticed your Master title… Havent seen it before…
After 4 years People still have Keys For those? Lol

I finally graduated, it seems. :stuck_out_tongue:

1 Like

Ye… I would like +100% plots too heh

Who wouldn’t, immaright? :stuck_out_tongue: