Release: 113 - Lighting changes and bug fixes

New Features:

  • Block lights now have a quadratic falloff, and have their luminance and spread reduced when crowded by other blocks to give a much more realistic lighting feel.
  • Added Field Of View to Graphics Options.
  • Added (non-developer) /setbuilderip command to chat so users running world builder on a different machine can still connect to it (eg: /setbuilderip 10.0.0.46). It uses TCP port 8903.

Fixes:

  • Fix for quick-use and backpack GUI numbers going transparent.
  • Fix for crafted sticks not stacking with sticks already in the inventory.
  • Hide the health bar when using screenshot mode.
  • Fix for error when entity does not exist on client.
  • Removed over-exposure in specular reflections leading to gleam being washed out to white when crowded together.
  • Fixed lighting inconsistency at LOD transitions removing the visible dark bands at transition points (does not affect liquid LOD transitions).

Note from Ben: Heads up on the lighting changes for this release:

With your help, looking at your builds and how you like to use lights in Oort, we’ve managed to come up with a new lighting model. It’s flexible enough to look bright with a few lights, but also looks great (and doesn’t look like a nuke has gone off) when you use lots. We looked at a lot of your builds while working on this to get the right balance.

This is however a significant change to the way lights work, and some builds will look quite different and might need some tweaks. We’re committed to this new model, and will keep tweaks in the future to a bare minimum to not affect future builds.

Thanks! - Ben

12 Likes

The new lighting really tames the glare on my bifrost on Vaisier. I noted the nuclear intensity the other “night” and this is a welcome improvement!

The issue with the LOD logic deciding that my four-walled fortress of dark glass and green gleam has one pink side is still there, though.

Whats the world and location of the pink side?

We will be regeneration the LODs in the near future.

Up close and personal:

At this distance, all is well:

Suddenly:

What’s interesting is that the green and pink error has swapped faces. Under the prior logic the facing side was pink and the oblique side was green from this perspective. The currently pink side could be made to change from a vantage point in the lake. I don’t know if that still happens, and I’m running short of time to describe it. If you want me to test it, I’ll do that after dinner tonight.

Meanwhile, sunshine through the hillside:

2 Likes

Thanks, will check that one with the regenerated lods.
There are a couple more case for holes we need to fix.

MUCH appreciated from a WorldBuilder multi-machine perspective! Thanks guys! :smile:

1 Like

Evidently there are new sounds, too. I now sound like some kind of perverted deviant as I dig through rock.

It’s not working for me. Here’s what I tried…

Linux machine (Ubuntu Desktop 15.04, IP: 192.168.1.33):

  • I ran WorldBuilder and started up a server @ 192.168.1.33:8194

Windows machine (Windows 8.1 Enterprise, IP: 192.168.1.6):

  • Re-installed OO (build 113) and fired it up
  • In-game, I hit the “T” key and typed “/setbuilderip 192.168.1.33” and hit return
  • Navigated to the “Teleport to a world” window and clicked the “Universe” selection box and it changed to “Builder”
  • Selected the “Final” world

Linux machine:

  • The visualization window reported “User connected (0) 192.168.1.6:12776”

Windows machine:

  • The screen in OO went blank and I got a “Unknown Error.” I could then “Select a Server” or “Quit World.”

It says above that this feature uses port 8903. Could this be part of the problem (my Mave editor visualization srtarts up a server on port 8194)?

@james, @lucadeltodecso

There are two servers involved here, one is the ‘discovery’ server (the universe) which runs as soon as the world builder starts up, this is the one that runs on 8903 and lists available game-servers (read: visualisation windows) which open on additional ports.

Some things you can try, though I’m not sure how much logging there might be: Run the world builder from command line to try and see if there are any additional logs from the world builder itself that wouldn’t be visible in the app, and take a look at the game logs too (gist it to post here),

So I tried it again, this time using my MacBook Pro and it worked. Here’s a screenshot of the Visualization window in the Mave editor on my Linux machine:

And here’s the results of the command line (from which I started the editor):


I also tried again with my Windows laptop as before and it failed again. Here’s the Gist of the OO log:

Further testing on my Mac while play testing a level from the WB server on my Linux machine yielded this error:

…at which point the world quit on me and I was returned to the “Select a server” or “Quite Game” screen. I’m not sure where to get a copy of the application log on the Mac. If you can walk me through that, I’ll provide a Gist of that also.

it will be /tmp/tblz_log.txt I believe.

Here’s the Mac OSX log:

same thing happened to me when I broke a grass block

… So the imgur album settings are gone or broken…

Anywho, The lighting is much better than 112 ^^. I haven’t explored deeper into the builds yet, but so far it seems that I may need to adjust to this kind of lighting to avoid a cluster of silhouettes at night.


Are these lighting bugs? (Also, in the minimap it shows that the pyramid is pink instead of green)

1 Like

The pink/green gleam thing is a known issue. The water issues here will be fixed shortly (it’s caused by the water being at a bad height in the world that means it is not flat across all LODs, and our current reflection system requires the water to be a fixed plane. We’re going to fix existing worlds by pushing the entire world up/down as required so that the water ‘will’ be flat).

  • @bigPharma, this is an issue from release 112 that is pending a fix.

Vool, thank you for looking in to it for me!