Text Color In HUD

I asked for someone to come take some screenshots on my build last night and when Aenea came I noticed something upsetting.

Here’s what I see when I wander my build, take a look at the location data at the top of the screen.

The first picture she sent me, look at this:

Is there any explanation for this, like I’ve set the text in some way that one PC can see it but the other can’t? Some kind of bug?

Language files could be the culprit


time to dig up some hex codes then

Everyone should use the 6 digit hex code…never the text. It doesn’t translate



Honestly the devs should just remove names colors and make it hex codes only. Maybe they could even automatically change all existing signs to hex codes to smooth the transition.

1 Like

I could be wrong, but I think they discussed adding a little color grid to the UI.

People with a different language setting than English in Windows will get the same result.

Funny thing is tho, my Win10 install is in English…

I believe there are local language files from Boundless and Steam has localization settings too.

Yeah but my language settings are as follows:

So it is kinda weird that the game didn’t show the correct colour for me since it should have.

Doesn’t change the fact tho that using colour names on anything besides signs (and chat text) doesn’t work if the other user is using a different language in-game…

Also, the game doesn’t support Dutch afaik


Like I said, the game doesn’t support Dutch and everything is set to English, even the game…

But I just found out why it’s doing it!

The colour number mod!!! It adds the number of the colour to the colour name, so simply typing black doesn’t work you need to type :#black 1:

In any case, hex codes always work with or without mods and with all languages!


Ahhhh, that explains it. Thanks for digging down to the answer!

1 Like

Weird, I’ve never seen it do that lol
I’ve seen it remove things before, but not add anything.
1 is the Boundless number for black so I guess it tried to revert to that for some reason.

The mod just changes the names of the colour strings, so black is then called black 1, and so on, which means that is also the string you need to type to get the text to display in black!

I’m glad you found something that worked for you :+1:t3:

I don’t know why it would accept that as the color code though @vdragon
Didn’t work when I tried it. I’ve noticed that when I venture into communities that aren’t English, I always see their code and color name text instead of the actual color when they don’t use hex.

You have that mod running then?

What mod? I don’t have any mods.

Then of course the number behind it is not needed!

I have a mod running which shows the colour names as having their index number added to it, it’s rather handy but does mean you need to type that number as well when using it like this…

I didn’t know you had 3rd party mods installed. :woman_shrugging:t4:
Makes sense now lol.