Anyone else infinitely getting this connection error when trying to start the game?

Same thing with another game?

Good idea. Trying that now.

Nope, tried another game and it launched instantly. Boundless is the only one in my library that I can see even shows this weird purchase button.

Nvm, I found another game with the purchase button that I own. Oblivion.


Uninstall and reinstall next option only if you have “In Library” Well it seems a steam problem

I think issue is that Steam don’t see you logged in. So restart Steam.

1 Like

And finally found a third game with this issue. Spore. It seems this maintainance has just bugged out random games in my library. I’m going try a full computer restart, then I’ll try reinstalling.

As said before

I’ve restarted it multiple times. Trying a full computer restart just in case.

Update: Restarting the computer didn’t fix it, so I uninstalled boundless. Boundless no longer shows at all in my steam library. Now tried logging out of steam and back in. Boundless still isn’t in my library and going to the store page shows that it’s in my library.


Does the restart solve the problem?

I put the update in my previous message.

1 Like

Sad news Maybe @james can help ?

Or take a look here

I am having exactly the same issue…


Shows a purchase button in the library, and a play now button in the store page. Clicking on “play now” opens up a loading window, then takes me to the library page with the purchase button.



Same for me :frowning:

1 Like

Did you guys tried to execute the game directly from the exe file?

Yes, same problem.

1 Like

Tried all of these steps, none worked and it appears that the file ClientRegistry.blob doesn’t even exist in my steam folder.

Looks like TONS of people are having this issue with random games

Someone is even saying it’s square enix games specifically.

1 Like

This is happening to me too. Clearly, something glitched during their Tuesday maintenance. Someone on the forums pointed out that the impacted games are all on sale currently. I am sure they will get it fixed… hopefully soon! I had serious plans for tonight! :cowboy_hat_face:


Have you all tried to “Verify the files” via steam?

Top left corner press steam and then press exit. Then open steam and see if it updates. I had an update from steam 2 hrs ago. 7-8pm EST

1 Like

If you press play Now what happen?

Maybe ??

So, my steam would not connect to the internet at all even though we didn’t lose our service with this hurricane. I just thought it was related.

I can get into steam now, but whenever I try to load boundless it just says preparing to load boundless… for longer than normal until it gives up and i get linked to the store page for some reason. Currently cant get on. My friend was just on before me, but he had already been logged in awhile and he is currently experiencing the same behavior now with me.

Yes, same here! Didn’t see this at first lol

1 Like