Beacon menu UI is acting odd

It happens just on the one beacon. I tried other beacons and they don’t do that. All beacons do all show 36-42+ beacons on the list now…which I think is cool, if it’s intended.

Someone on our discord (I don’t have this problem) posted this:

1 Like

I am having the same exact problem as what you show in the video.
Long list, words moving, transparent menu, missing stuff…

is this on console or pc? I had a somewhat same issue but to that extent and all i did was a video card driver update and it fixed my issue. Have no clue what may have caused it but it worked :slight_smile:

Just had this issue this morning, never before
i7 with a gtx1050

That’s a nice gpu you got there lol I’m on PC too.

1 Like

One day, in my dreams, I’ve have an i9 with an RTX :heart_eyes:

1 Like

I have an RTX 2080 and a simple driver update fixed it up for me. look into driver update to see if that helps.

my ps4 has a light on top


The video is mine. The screenshot posted is not.

1 Like

well there was a server maintenance like 5 mins ago see if that helps anyone having this issue :slight_smile:

That looks really strange. Did it occur a few times since the video was recorded?

Yes it is still happening & I restarted the game. This is the 1st beacon shown:

1 Like

Just now

1 Like

By the looks of the image, it’s guild names pushing things out of alignment

Thanks for the report. I think I have a fix. We hadn’t tested it with >150 contributors…


Is everything now working okay after the hotfix was pushed a few days ago?


Sorry, I missed this post. Everything has been working great, thank you :+1:

1 Like