[BUG] Question marks on number display

Encountered a strange number display issue after the new patch.

Additional screenshots

Is there anything I could do on my side?

1 Like

exactly the same problem. changing language didnt helped

Try changing language from auto-detect to english. It does show on my client numbers then right way.

Previously, there was an issue where someone reported that the character  was appearing in place of the thousand separator, but it now looks like a different character appears instead. In any case, thanks for the screenshots. I’ll add these to the bug database.

You need to restart the client aswell after the change, as prompt when exiting the settings.

What is your PC locale set as (ie language and country)?
It looks like the numbers are using an unsupported character.

Were you seeing a correct separator before the update?

I had English set in options. But afer the last patch i get ?? . Tried to swap to other language,reset and back to English,resrt. No result

And PC is set to polish language

I have same problem too. I play on steam. My steam language is englsih and my windows 10 language is hungarian.

Same problem. “?” sign in place of 4th digit in numbers.
Appeared afetr last patch (Release 198 13Sep). Before all was right.
Changing language doesn’t helps.

Same problem here, the digit in the thousands position being replaced with ? in all numbers. Changing language did nothing.

So, switching the formatting in Windows from Swedish to English fixed it for me. My friend who’s also running with Swedish formatting doesn’t have this issue, but he’s on Windows 10 and I’m on Windows 7 so that might figure into it.

I have same

Im on windows 10 change language change nothing

Saw strange char, change language from auto detect to English, clicked confirm, game quits, I start it again and problem is gone. Windows 10 with language set to English, and region to Poland (because US English have the most stupid date formatting ever :wink: ).

The problem was some locales (language and country) use characters for numeric separators (eg the non line breaking space) we were were not correctly dealing with and that are not in the font we use.

It should be fixed in the next update by replacing them with supported one.


So every time an amount ingame reaches beyond 1000, instead of the number of thousands a “?” is displaying, so e.g. 1200 in my game looks like ?200. But I don’t have an actual idea how much coins do I have. Does anyone know how to resolve this issue?

@michaelb any ideas when the patch will come on live? this is really frustrating when you dont know whats the price of items in stores is it 1000 or 9000? :smiley: hope it will get released soon?

@michaelb I am sorry to bother you but how long it takes to change font in the game? It’s more than week but it seems one character in font is stronger than 25 developers. I don’t want to be rude but this is a big issue, very annoying and the first thing what possibly new players see. So they can imagine how flexible developers are if they can’t even fix one symbol in the game. I enjoy the game as it is, it’s great fun, i am building my preciously chiselled house in our settlement, it’s time sink as hell. BUT PLEASE, do something with it. Or at least tell me what i can do with it. If it’s hard to change font so just remove that symbol for now and fix it later or change it with just space, anything is better than nothing. Thank you kindly <3

Because of the way the game is cross-platform, it’s not possible to release a quick patch just to fix one thing, even if it’s something straightforward. At the moment I know there are lots of fixes being tested, so hopefully this will be one of the things included in the next patch - hopefully next week.