Cant complete objective to join settlement by refuelling beacon [SOLVED]


#1

EDIT: To anyone reading this now, I have noticed on both my main and on multiple alts now that this objective can take up to a few minutes to complete after you place down the beacon. This can really puzzle you or even prompt you to take down the beacon and replace it again. Instaed just try waiting a few minutes and see if the objective dont update by itself

—.

I put the fuel into the beacon and click refuel, but the objective does not get completed. The previous objective about placing the beacon just next to settlement got completed when I placed the beacon, so it should be at the correct location. This is my alts beacon and I am trying to join my main characters settlement.

This beacon is set to be my home beacon. I tried fueling the beacon both when it was master control and not master control, little did it help.

Hope someone can help clarify what I am doing wrong?


#2

With the changes to prestige that plot might have to hit 10k. I’m not entirely sure tho.


#3

I dont remember this objective 100%. Did you place the beacon outside of your main’s beaconed plot? So when you place the new beacon down you should see the white box outlining your whole plot instead of the green box inside the main’s plot.

Because if your alt has permissions in your main’s beacons you would be able to just add more beacons but wouldnt claim any additional plots if that makes sense.


#4

My alt has all permissions for main characters home. But the beacon I am refueling is placed (by the alt) in the plot that belongs too (and was plotted by) the alt. So it seems I am doing what you suggest. Maybe I need to destroy this beacon and make another one?


#5

But that would make the alts plot a settlement in its own right, would that really be necessary prerequisite for joining a settlement? That doesnt sound entirely right though that to join a settlement your plot must itself be a settlement first.


#6

You could try getting prestige to 10k as fire suggested. That might be it. If they’re touching it would all be considered one settlement


#7

ok cant hurt to try, I will up prestige on the alts territory.


#8

ah I just realized that my alts beacon is ALREADY part of the settlement. I realized this coming back from farming and when I went into the alts plot the message on the center of the screen “you entered unnamed settlement” ( I didnt name my mains settlement yet lol).

So I guess I have to leave the settlement and then rejoin it to be able to complete this objective (I consider this sort of a bug, the game should be able to register that I already joined and then auto complete the objective).

Anyway, do you know how I can leave a settlement? Do I just remove the beacon and then that is that?

EDIT: That worked! Weirdly enough after adding the fuel it took more than a minute for the objective to actually complete. I was just about to write another reply that it didnt work when I heard the Objective complete “ding” sound :blush: hurray :sunny:


#9

Just make sure there are 2-4 open plot spaces between your Alt’s beaconed plots and your main one (none touching). That should cause your Alt to “leave” the settlement.

Are you a PC or PS4 player?


#10

PC. I found out to fix it by removing the beacon, then placing it again. I just placed it right next to the main settlement again and plotted two plots right next to it and that worked. I think the problem was that I had joined the settlement earlier, before the objective to join became available.


#11

I don’t know if you’ve used this yet, but if you run into settlement/bridging/road problems - the debug info can be helpful. (If you see a line of 3+ plots in a row that are red, that will usually cause a problem.)

Main Menu > (game) Settings > Debugging > On
F1 > Beacon/Settlement Visualization

plots2


#12

oh no I haven’t, I didnt know that. I definately will take a look at that too, thanks!