Can't start client with proton

Tags: #<Tag:0x00007fa0d218cc78>

Ever since today I haven’t been able to start the game up with steam/proton. Does anyone have any experience debugging this? I would appreciate any help or advice. Thanks!

A Linux person! Cool! Didn’t know we had any of those :blush:

Yup! I’ve been a Linux nerd since I was a teenager and loving it ever since.

I’m just really glad this game works at all with proton. I’ve been playing it for about a month now and it’s been awesome.

I was able to get the game going on an older version of proton, but it has its issues. I’d really like to get it going on the newest release, but I’m just happy that I can play.

This game and its community are the best! I’ll update if I figure anything out so other Linux users can enjoy the game as well.


One of the reasons I backed the game so long ago was because they promised first-class Linux support. That all changed when they moved away from the in-browser game to a native game. Although they still have a Linux client they use in-house, they said they lacked the resources to do first-class support for that target so they chose to just not do it. Fair enough, it’s a business and I respect that.

Funny thing, I was working at a major Linux distro at the time. I had a full-time engineer devoted to making sure games worked well. I had gotten the browser-based Boundless to demo 3D rendering on our phone product and I wanted something really cool to demo on our next-generation converged desktop, but we ended up having to use DOTA 2 because of their Linux support instead of Boundless.

Anyway, Linux support has been off the Boundless roadmap for a long time now.

1 Like

What actually happens?

Are there any error messages from Proton?

Anything in the Boundless logs?

Just adding that proton is working fine for me. The version I’m using is 5.0-7 (which is the latest for me). Do you have a different version?
Something to try would be to delete proton so it re-downloads (looks like its stored in steamapps/common) Sorry I can’t offer any better advice.


What actually happens?

The game just doesn’t launch. I click the play button, it turns into a stop button, then a few seconds later is a play button again.

Are there any error messages from Proton?

As far as I can tell, these are the logs I’m able to generate from proton (renamed logs with .js ending so I could upload):

steam-324510.log.js (1.3 MB)

Anything in the Boundless logs?

I’m not sure. Where are the Boundless logs stored?


Linux support has been off the Boundless roadmap for a long time now.

Yeah, I do understand why they don’t back Linux from a business perspective. I don’t hold anything against them, I would have probably made the same decision as them if I were in their shoes.

I just think it’s a bit of a catch 22. Games don’t support Linux because its user base is small. The Linux user base is small because games don’t support Linux. In my opinion, the amount of software supported for the system is the only advantage other operating systems have, but I digress.

@willcrutchley Thanks for the advice! It took me a minute to figure out how to reinstall it, but I eventually did. Doesn’t seem to have made a difference unfortunately, but it was worth trying. Editing to add that 5.0.7 is the most current version I can’t get working. I’m able to get it running on 3.7.8 though.

I would much rather use Linux than windows if not for this issue.

Under Proton the Boundless logs should appear in a path something like this

.steam/steam/steamapps/compatdata/324510/pfx/drive_c/users/steamuser/Local\ Settings/Application\ Data/Turbulenz/Boundless/log.txt

@sej also I think something went wrong with that upload renamed to .js at least I can’t seem to download it, might be easier to just email us the logs at I’ll see them if you send them there.

I used to play using proton on Linux. I had to correct some dlls to get it working. I play in windows now and have not tried proton in a long time, but my solution is still listed here:

@blake I just sent out an email. Thanks for taking a look, I really appreciate it.

@Tonezone I’m going to give that a try now. :smiley:

I gave it a shot and it doesn’t seem to have done anything. It was definitely worth a shot, thanks for the advice!

@sej (I only took a very brief look), the logs showed up a couple points of interest.

proton is not letting the chunk cache work… it is failing to create the database, perhaps proton fails with mmap which is used by the cache in the client… but that just causes it to get disabled (which is a point of warning, that it will use much more bandwidth than would be usual as itll be constantly downloading the same chunks again and again when theyd normally be cached).

main point though, it appeared that (all?) http requests from the game were failing as well and it was causing you to get into some unhandled edge case triggering a crash in the client.

1 Like

That’s interesting and it explains why the game has been so painful to play lately, lol.

I just bought a new computer, so hopefully all of this is moot once it arrives.