Core Objectives Bug?

Tags: #<Tag:0x00007fb4d363e658> #<Tag:0x00007fb4d363e568>

Not really used to forum posts, so apologies beforehand.

tl;dr “Buff It Up” objective won’t trigger, no idea what to do. Also please fix “The Great Replenisher” or at least remove it.
I’m a wannabe achievement hunter, but this is on hold now due to the amount of time this game has been occupying. Noticed there’s still plenty of achievements I haven’t obtained even after ~650 hours.

Decided I should go for the rarest one (on Steam), “Getting To The Core”, which I can’t obtain due to not having the remaining quests available. I assume the “Buff It Up” is preventing my last 2 core quests, “A Gem of a Journey” and “A Very Special Search” to activate since it’s not finished.

Am I doing anything wrong?

I think this one is broken. If it’s just that I missed some branch or objective being unlocked I’d sure like to know what it is.

I can’t find “Buff it up” in available or completed, is it a core objective?

As per this link it is indeed a core objective. Latest edit was Oct '19 though.

1 Like

The “Join a Settlement” is the one that is most frequently reported broken last I checked.

Thanks for the link, there are a couple of others I don’t have too.

Based on what they are I might guess it’s due to having done all of the activities before triggering the objective or something.

Of course it could also be triggered by objectives outside of the core group and I have never gone solely on a quest to complete objectives across all professions with one character.

@lucadeltodecso can you offer any help/advice here? Besides the OPs quest I would need to trigger:

  • Buff it up
  • A gem of a journey
  • A very special search

I’ve done everything required for the first two. I’m not positive I’ve mined all three lucents on my main since I frequently used a miner alt but I would need to trigger the objective anyways.

EDIT I just noticed that I have mining survival challenge I, II, and IV completed and don’t have a mining survival challenge III available or completed :stuck_out_tongue:

The “Join a Settlement” is the one that is most frequently reported broken last I checked.

I remember I had some problems with that one initially, but I just went to an unknown nearby settlement and placed a beacon with 4 plots. After that it was sorted.
It also triggered “randomly” on my alt character due to connecting to my plotted area.

It should still have a specific trigger, I tried unlocking skills (on an active skill page) that I never used before, like rage epic, focus, gear crafting epics etc. Nothing triggered other quests as far as I observe.

I thought of that too, I still have some objectives left that I couldn’t be bothered to work on since I assumed at some point I’ll get them done. I will try to get as many done as possible tomorrow. I’m bored and waiting for the update anyway.

I’m also missing the same exact 3 objectives, maybe they were removed? Broken? Who knows.

I definitely did mine all 3 lucents so it’s not a problem on your end.
I’m also missing Mining Survival Challenge III lol never thought of checking it out.

What Guild Buff were you using? It’s working fine for me, but it could be that you may have come across a Guild Buff that’s not causing the objective to be completed.

I don’t even have the objective in my journal.

I’ve run several of them, spark and wear, grapple and run, lava protection, hammer versatility, the cooking buff, and the builders buff, off hand. Maybe more.

The same for the other two mentioned objectives, it’s not that they don’t complete, they’re not appearing in the journal.

I only ever benefited from Grapple and Run, Builder’s Buff, Building Safety and Hammer Versatility as far as I remember. Those were never activated by me. I tried to activate a Grapple&Run for my solo guild but to no avail.
What would be the required steps to get it? (show up in my journal basically)

Ah, that explains it. You’ll have to complete more objectives before new ones become available.

Just opened Boundless after the update and it’s now been fixed. At least the Buff It Up objective.

Err, you mean “fixed in today’s update” right? I did literally nothing and it’s in my list now.

How about the other two?

EDIT:
I finally got the chance to log in for more than a moment. It will have to wait until you can activate another guild buff. Here I am with a pre-existing guild buff enabled:

I added another guild buff now that the buff it up objective is available and immediately got both the objective and the “Getting To The Core” achievement in steam.

I guess this means that “A Gem of a Journey” and “A Very Special Search” are not/were not actually acquired for the achievement? In any case they’re still listed in the wiki page as core objectives but unavailable to me in the game.

I guess we’ll be seeing “Getting to the core” shooting up in percentage of players over the next week :grinning:

2 Likes