Error Message while Rendering [Worldbuilder]

The apllication in 0x3fbb98b9 refers to memory 0x00000000. The process “read” could not be performed in memory.

Well, do you know about that? I get this error when I try to render this:

It’s about the “three dee land” and the 3D Noises. Might it be that they shouldn’t be combined like that? I saw how the Product Noise did an awesome Cavedesign and thought I could use it to make awesome rocks on the surface, but it seems like I cant.

@james, you answered all my last questions so I guess thats your area? ^^

try adding a noise to the product noise (simplex or something like that). I don’t know if that’s the problem but it’s worth a try

1 Like

Tried it, but I have the error as long as I use an Noise that’s not Perlin, Simplex or Worley…
Maybe they’re just for Caves?! I dont know.

I’m going to have a look at it :slight_smile:

I’m sure @lucadeltodecso will know.

1 Like

works for me…

try to add a perlin noise with low frequency

1 Like

Hmmm as this is already a Worldbuilder bug report i thought i could report this here:

If you while connecting segments deletes the segment you are making a line from, you cannot unselected the line and the Worldbuilder will crash when connecting the line to another segment.

Save your world, close and reopen the worldbuilder, open it up again and try now. Usually I find the error codes go away after that.

I would say you need something attached to that product noise though.

1 Like

I tried everything ^^ I guess there’s not an problem with the Worldbuilder itself… but I dont know where to look for the problem to post it here, too.

Try visualising each of the nodes independently - you might find the node that is unhappy.

Also - make sure that each node has all the inputs it requires. (For example the product noise node looks like it needs an input.)

However, you’re right the app shouldn’t fail - it should help you find any issues.

@lucadeltodecso can say more.

1 Like

Well I tried anything now but I dont even know how to get an logfile with the Error to see what happend ^^ I just wait for @lucadeltodecso to answer here :smiley: Maybe he can tell me what I did wrong or how to get an logfile.

Oh and as I said, I only can use the Perlin, Simplex and Worley 3D Noise (Didn’t tried out the other noises in 2D for now)

If you could share your config file, I can take a look from here. (gist.github it)

1 Like

You mean that, right?

-Link deleted-

No i mean the world config file that you save/load in the world builder.

Then its this one

It’s because your sum-noise node on the three-d islands has a function missing, delete that empty term and it’s fine.

I agree the editor could be more forgiving/and-or helpful in reporting these user errors :sweat_smile:

Thanks ^^

I’ll see if I’ll still get the same error, cause sometimes It even appears when everything has an connection, maybe I just didnt notice an empty space, I’ll say if there are more problems anyway but thanks for that :smiley: Now I can finally finnish that Biome after 2 Days xDD

I can not enter the world builder because of error code 126. please give me advise what to do