Extreme rubberbanding

I went to build my new base on galan and I cannot even move when I run I find myself in random spots…I tried placing blocks and just getting nowhere…I have never had issues ever before on galan. I am not getting any check internet message or anything…even when I go to sanctum the countdown is even
rubberbanding…it’s just so odd…got to Adler and it’s fine.i am in Australia if that makes any difference…is there something funky going on?

I’m having problems with galan too unplayable connection, takes like 20 seconds to go back to sanctum rubberbanding all over the place when does let me move for a couple of seconds.

1 Like

Everywhere else is fine my base is on alder no problems there I’m on the east coast servers and ps4

1 Like

Galan is an Aus planet, so you might be experiencing lag if ya not near Australia

I live and operate in Aus…lol

oh my bad, missed that part - im not sure then, been facing issues on and off according to lots of people, not much we can do but hope it clears up I suppose.

I get crazy rubber banding on mkrib and never have before. It’s my RR feather. Hunting grounds now I can’t even walk around it without getting kicked or running into wall cuz the rubber banding

Uea its working now…just first time i ever experienced that bad ever…normally if internet issue I will get booted or crash…but this was a lot different…anyway

Look for Khalis in TNT first floor or hunt hive ground floor to bypass galan and houchus tho galan maybe stopped 10 mins ago. Im eu, in case of lag or rubberbanding

No I want to be on galan…buts working now thanks for all the advice