Game stops responding while trying to connect to server

In the Steam client, I have had the game stop responding when clicking to connect to a server. The same happens with the “” client but instead of the browser not responding, the game just freezes forever. I have tried everything that is currently posted on this forum, such as reinstalling, turning off antivirus, and disabling firewall, but none of the solutions worked.

Game log:

Can someone help me please? I have just bought this game and have not been able to play it since. Also, a more recent problem is trying to launch the game causes it to freeze at the “Connecting to discovery server…” screen and stops responding after clicking.

Sorry - for some reason I didn’t notice the original post.

I can’t see anything obvious in the log at the moment. It’s possible you were hitting an issue with our inventory migration scripts.

The game log you’ve posted is: 101.1
Latest version is: 101.6

Can you confirm the current release also fails?
If so, please post your latest log file.

1 Like

Yes, the current version still stops responding at the “Connecting to discovery server…” screen.

Again - there is nothing obvious in the game log - drat.

  1. Has the game ever worked for you?
  2. If so, a rough estimate of when it stopped?
  3. When did you first play the game?

We will need to investigate this in more detail. Sadly at the moment I don’t have any quick suggestions for you to try.

Can you share the output from the browsers console log? This might contain some clues.

I’ve only had the game work on other computers other than my home PC, but only on mine the game has never loaded into a world. I’ve also only been able to try the Steam client on my home PC due to lack of installation permissions on the other computers.

The first day I tried playing the game was the day before the original post and the error I encountered then was a little different. The game would load and transition to the server select screen, but when I clicked a server the game would immediately stop responding. Ever since I either disabled my antivirus or the next patch, I have not been able to load past the discovery server screen.

As for the “” client, I have been able to get past both of those issues but the game freezes at the “Meshing chunks…” screen instead and will never place display the world. I do sometimes hear the ambient sounds while trying to load in, but nothing else. If I click “Cancel” before the game freezes I can connect to a server other than auto-connecting to the previous server on startup. Even then the game still freezes on the server select screen, but only a few seconds after canceling the previous connect.

I’ll list a few programs or such that I’ve tried disabling for possible interferences: Emsisoft Anti-Malware, OpenDNS, Windows Firewall, forwarded ports.

Here is the console log:

Still having the same issues in Release 102. (Bump)

Thanks for the bump.

Hmm, this line is an issue:

TypeError: d.smoothNormalsTargets[0] is null

I’m going to ask the team if they have any ideas.

Update Version 104.3: Still having the same issues with both clients, nothing different happening on either one.

Can you get in to the options screen?

If so can you toggle the options ( press o) for

  • Pre-pixel Lighting
  • Smooth normals
  • Advanced Block Lighting
  • Advanced Entity Lighting

and restart.

Also have you tried teleporting to another world - press o for options and then choose a different server?

I am not able to get in to the options screen from where the game crashes (for the Steam client, the discovery channel screen and for the web client, the meshing chunks screen.)

Looking in the logs it seems you mainly been trying the web client.
Can you try the steam client again and if it still does not work post an updated gist?

Sadly, the Steam client still does not work (as of patch 106.2)

Sorry your still hitting an issue.
a) If you leave it running for a while, eg 10 mins, does anything happen?
b) What kind of internet connection do you have and do you have any issue playing any online games?
c) where are you based?


I waited a few patches to see if the game would run, but it still does the same thing for both clients. The only difference is that in the “” client, it takes a few seconds longer to freeze and makes a brief noise that sounds like the character is being placed on sand.

Even if I leave the game running for 10+ minutes, the game still does not respond. I have no issues playing any other online games. Reinstalling the game also didn’t cause anything to happen differently.

I don’t understand what you’re trying to ask in the last question.

Game Log (update 108.4):

Browser Log:

I checkout your character and its appear ok, ie logs in and spawns on lotad correctly. In the logs I don’t see the Steam client attempting to connect for you but I do see the browsers version logging in. You mentioned you had already disabled the firewall etc but this feels like the most likely area that something is blocking the connection, though no errors are logged.

The browser issue you saw is an issue we have seen on Firefox. If you try Chrome it should be ok but the Steam client is the main way to play the game.

On the location question I wondered if you were far from any server but it looks like you should be ok.