Issues launching from Steam (8/13) (dx11)

Hey all. As the title suggests, tried to launch from steam and the game crashed. I just get an error message saying “Oort has stopped working”. I’m launching the dx11 version. Please let me know what further information you need and how I can get to that information! Thanks!

1 Like

Some common things the devs ask is what GPU and driver version you are using. Also, they ask for crash logs. This info might help the devs get to the bottom of your issue. I hope all is fixed for you soon.

1 Like

Can you post your log which should in %LOCALAPPDATA%\Turbulenz\Oort Online\oortonline_log.txt on a gist https://gist.github.com/ ?

Updating drivers can fix some problems.

Here we are: https://gist.github.com/6ceb5bb7d3916003eff5.git

Link doesn’t work for me. Is it possibly a private link?

I clicked public, but I’m getting a 404 error now. Trying again.

Ok, keep getting 404 errors, so I pasted into a google docs instead. Hopefully that works?

That worked. There no obvious error being reported.

a) Has it worked before?
b) Its finding a Intel® HD Graphics 4600. Is that your main GPU?

The Intel HD Graphics 4600 is DX10 class hardware and the current DX11 version only works with DX11 class hardware. The next update should have the DX10 hardware support.

So switch back to OpenGL, though for Intel GPUs we know is slow at the moment.

Yes, the integrated graphics is the main GPU. This laptop was a gift many years ago and that GPU has been a noose around my neck.

DX11 had been working wonderfully and solved all of the lighting issues I’d once had with the game. Now the game won’t launch with OpenGL either.

It’s likely the DX11 version and OpenGL (default version) are failing for different reasons.

  1. The OpenGL version is likely failing because a shader is failing to compile. (I could confirm this if you shared a gist of the game’s log when running the default version.) This is happening because the game is using a legacy rendering path for your Intel device. This is why we’ve been gradually switching to DX11.

  2. The DX11 version is failing in a strange place. It’s failing without reporting why.

  3. What OS are you running?

  4. Is it OS fully up to date?

  5. I’m assuming you’ve already done a system restart?

It would be good to try and work out what is happening in the DX11 build.

  1. Have you changed your hardware config at all recently?

  2. If you have additional devices plugged into your machine, try removing them temporarily. (For example, multiple monitors.)

  3. Please make sure you have a suitable sound device setup. We know the game can fail if there is no sound device detected. (Something we really must fix. Bad us.)

Actually hadn’t yet. So I did. Still not working for OpenGL, here is gist. It gets me to the “click to connect” screen and then I can’t actually click to connect.

DX11 actually opened and played fine for a few minutes until I tried to TP to Kovah’s capitol. Here’s that gist.

Haven’t changed hardware recently, only thing plugged into this laptop is my mouse, and the sound with the game has worked fine using internal speakers before.

I’m running Windows 8. I’m being told there’s an update to Windows 10, but I’ve been putting that off since game seemed to be fine in Windows 8. But if you think it will help I can fall on that sword.

As suspected the OpenGL version is failing because of a failed shader compilation. You’ll need to stick with the DX11 version.

Hmmm. There isn’t sufficient logging to really know what is happening. It’s possible the server state is somehow unhappy. We have rebuilt the world a few times last week. It’s possible that this has corrupted something for you. @OortSimon is there anything strange from a server perspective?

If you restart - can you switch and play on other worlds?

If you restart - does Kovah come up at all?

Went to check if I could retry and I got the original error message again, which says,

"Oort Online has stopped working

A problem cause the program to stop working correctly.Windows will close the program and notify you if a solution is available."

Can you share the log again - just incase there is anything different in it?

Sorry, stepped out for a bit. Here’s the log:

I had the same problem on my Alienware Laptop that is used to play on without a problem. It occurs for OpenGl and Dx11 modes. But I fixed it by selecting the correct video adapter.

For longer battery life, the laptop has an Intel® HD Graphics 4600 and a NVIDIA GeForce GTX 880M card. To use the 880M, I have to configure it.

Oort crashes right away on the 4600 and works fine with the 880M.

What OS are you running? Windows 10
Is it OS fully up to date? Yes
I’m assuming you’ve already done a system restart? Yes

Gist for when it crashed

Ok thanks for the log and details. I have seen other users report logs that end with:

onsoleobject.cpp(274):                 (turbulenz::ConsoleObject::LogCB) CONSOLE LOG: MeshWorkerManager onMessage WORKER_CREATED
consoleobject.cpp(274):                 (turbulenz::ConsoleObject::LogCB) CONSOLE LOG: WORKER_CREATED

These aren’t errors or failures - but are the last valid things reported before the game fails. Clearly it your case it was related to the dual GPUs. We need to do a better job supporting these configurations.

When you switched GPU did you do it using the Nvidia control panel eg

http://nvidia.custhelp.com/app/answers/detail/a_id/2615/~/how-do-i-customize-optimus-profiles-and-settings%3F

1 Like

As far as I know, I only have the 4600 GPU, so my issue isn’t with dual GPUs even if Tahru’s is.