Lag :(

Hello there, i got lag almost on all servers :frowning: I’m playing World of Warcraft, Test Drive Unlimited 2, Marvel Heroes, NFS World, Tree Of Life, Elder Scrolls Online, The Crew, Hearthstone, Starcraft 2, Diablo 3, LoL, HoN and etc without “lag”… I have asus gaming laptops(12gb ram on lowest one.) with 8mb per second connection. All drivers are up to date. Will it be always like this for my region? (Location: Turkey.)

Are you definitely on the EU servers closest on your region? I got some lag after i used the world selection accidentally put myself in a USA server.

I’m on the EU server.

Which graphics card are you using? Would it be this?
NVIDIA® GeForce® GTX980M 4GB GDDR5
Also, I assume you are playing the game through Steam and not through ga.me (browser)?

Thanks

NVIDIA® GeForce® GTX670M 3GB and NVIDIA® GeForce® GTX780M 4GB. Yes, we are playing through Steam.

Can you let us know the following.

  1. Ping time
  2. Frame rate

You can get the debug info by pressing the . key.

Thanks

East EU

Central EU

15-30 FPS almost all servers.

Hmm… it may not be network related. We will look into this issue this week. Sorry about this.

cant wait till we gt directx11/12 support

I got more lower FPS after Dx11 Pacth :frowning: It’s between 15-23 now. It was 15-30.

Which graphics options do you have enabled / disabled?

It’s better now but no weather effects, no birds, no advanced options. cry

Additional; when i run, fps goes down again sometimes with lower settings.