Mapping the World quest issue


#1

I have been running around with my atlas out and I can’t seem to complete the first portion that says “Find a new region using the Atlas and Compass”. I have found new regions with my atlas out but it doesn’t complete. I did manage to complete the next two parts (found copper ore) but am I doing something wrong for the first part?


#2

Were you holding the atlas in one of your hands at the time?


#3

I was yes.


#4

I’ve not been able to reproduce this so far. Were you trying to carry out the task in particular way? For example:

  • Are you only trying this with one atlas or many atlas?
  • Did you try this on more than one world?

And anything else that may be worth mentioning.


#5

It may be worth noting that when the text above your compass say “East of ???” then you have to run west to get there. You need to go in the opposite direction it says to discover the region


#6

I’ll hop on in a few moments and run off in a direction to try to trigger it. Hard on my world since there are loads of water ways with high cliffs so it’s annoying to run long distances. To answer your questions, I was doing it with one atlas on my home/starter world.


#7

Well, it worked this time. Was running around holding down left mouse button - not sure if that makes a difference but it completed. Sorry for the confusion, I assume I did something wrong or screwy the first time.


#8

I’m also having this issue. I’ve unlocked 2 regions now one while zoomed in and one while it’s just in my hand.


#9

Hello I also had this issue and googled to see if there was a workaround but this is the only thing that came up.

I struggled really hard with this, I’m not sure I can give a total game state of when it wasn’t working and how I got it to work but I’ll try to list all relevant information:

I have item selection radial switching set to primary hand instead of both hands.

Usually I have my atlas or a gleam block set in my off hand (right hand), and scroll through my different tools in my primary hand (left hand)

I was using an atlas in a smart stack of atlases

I was logged in for a very long time (10 hours?) when I started to do this quest, who knows what random prerequisites happened to cause this bug

I tried having the atlas just in my hand, and I also tried actively holding the button to zoom into the atlas as I discovered new areas.

I tried switching hands.

I tried closing my game and re-launching.

(I discovered about 8 new regions in the process of trying to figure this quest out)

Finally, I decided to remove my atlas from my smart stack of atlases, unequip it completely, and then put it in my primary hand with nothing in my off hand. I also held the button down to zoom in. When I discovered the next region it finally worked. My guess is that it either has to do with the atlas being in a smart stack or possibly which hand its in / whether you are dual-wielding items. I figure closing my game and re-opening it probably rules out any related problems to leaving the game open too long. I’m not entirely sure but I tried to provide as much relevant information as I could.


#10

Same issues. Finally figured out it needs to be in your left hand.