Mod Manager and Mod Collection

Thanks for that. :slight_smile:

1 Like

Hello, I followed the set of instructions, and everything is working well. I have one problem, however, and it’s that I cannot edit the json file to change the desired mods to TRUE and undesired mods to FALSE. My windows computer just wants to open up the mods file with a “File Viewer” and says i cannot edit the file without upgrading to a premium version. Anyone know how I can fix this without having to spend money?

Open the file in notepad or some other text editor instead of “File Viewer” and I believe you should be ok.

1 Like

There’s an amazing free and amazing text editor known as Notepad++ that I use for .json editing, text editing, config editing for Minecraft Modpacks, among other uses. It’s an amazing tool for the purpose it handles.

2 Likes

I tried opening in notepad and json files simply do not show up. I can go to the exact location of them, but the mods folder will be empty :grimacing:

I will definitely look into that, thank you :slightly_smiling_face:

I think thats because notepad doesn’t recognise JSON as a supported format but if you manually open the file with notepad from file explorer it should work (if you right click is there an “open with” option or something similar?)

(Or from notepads open window if there’s a dropdown below the file name towards the bottom where you could select All Files instead of supported extensions)

1 Like

Well thats the thing, I tried open with… and I tried to open the file with notepad under File -> open but it simply does not appear, even though it does appear if I go windows + e and find it.

In the open file dialog in the bottom right above the open button there’s a drop down that says Text Documents (*.txt). This basically filters out all files that aren’t text docs so if you click it and change it to All Files it should work.

1 Like

That was exactly my problem, switched to all files and I can now edit in notepad. Thank you for the help!
Thank you to all who helped :smile:

1 Like

I’ve tried to run this but all it spits out is

Compass Higher Cardinal Directions by Onni - Raises the compass cardinal directions higher for better visibility. (mod_Compass_Higher_Cardinal.json)
Applying changes to: …/assets/gui/layouts/common/compass.json
Traceback (most recent call last):
File “F:\SteamLibrary\steamapps\common\Boundless\applyMods.py”, line 56, in
with open(relativePath, encoding=“utf8”) as json_target:
FileNotFoundError: [Errno 2] No such file or directory: ‘…/assets/gui/layouts/common/compass.json’
Press any key to continue . . .
The thing is that the file exists, I can navigate to it manually. Beyond confusing.

You want to make sure applyMods.py is located in a subdirectory of Boundless rather than within Boundless/ itself.

You should put all the mod files into a directory called “mods” (for example) so you have
F:\SteamLibrary\steamapps\common\Boundless\mods\applyMods.py

the “…” at the beginning of ‘…/assets/gui/layouts/common/compass.json’
means that the program is first going up by 1 directory level before going back down into assets.

1 Like

Wow that made it way happier. I thought the … was notating it was starting its search from the directory it was placed in.

Has the colour numbers mod stopped working for others?

Edit dont worry just applied again from :Color numbers in tint description

Guess it was the update.

Also think it “breaks” it if you go to test, then back to live if the test has a newer version of the file.

I get this error and dont really know how to fix it

Traceback (most recent call last):
File “G:\Steam\steamapps\common\Boundless\mods\applyMods.py”, line 48, in
with open(file + “.json”, encoding=“utf8”) as json_file:
TypeError: ‘encoding’ is an invalid keyword argument for this function

Make sure you are using python version 3.x instead of python version 2.x.
You may need to do some of the following:
Install python3
Find out what terminal command corresponds to python3
Edit the applyMods.bat or edit the applyMods.py file
If you edit the applyMods.bat, let’s pretend your python command which opens python3 is “py”
Then you write the line
“py applyMods.py”
If you edit the applyMods.py file you need to figure out the path to the python3 binary and put it in the first line where “#!/usr/bin/python” currently is.

At each step make sure you fully understand what you’re doing… don’t want to accidentally delete all your files.

yea got Python 3, but previously had python 2 installed, i just edited the py file with the directory for the for the python3 and that seemed do the job the script ran, cheers

1 Like

I’m very sad.

I downloaded and installed Python, but I can’t seem to get applyMods.py to open with it. I’m not sure why.

This is what it says to me.

D:\Steam\steamapps\common\Boundless\mods\applyMods.py
File “”, line 1
D:\Steam\steamapps\common\Boundless\mods\applyMods.py
^
SyntaxError: unexpected character after line continuation character

could anyone help me with the water mod? if i enable it and run the .py in the idle, i get Traceback (most recent call last): File "C:\Program Files (x86)\Steam\steamapps\common\Boundless\mods\applyMods.py", line 60, in <module> iChangeOnFile += changeValue(targetData, changeKey, changes[changeKey], modsJson["revert"]) File "C:\Program Files (x86)\Steam\steamapps\common\Boundless\mods\applyMods.py", line 18, in changeValue jsonPath = jsonPath[key] KeyError: 'waterGamma'

but the other mods i’m wanting work and it states changes applied/already applied.