Problem with prefab


#1

Not sure if i do wrong, or if it is bugged.

When i start a new prefab, i can place 1 block, then the blocks start to vibrate and the prefab is gone (or i am…).

I can press “teleport to” then i can see the prefab in front of me again, but now no move-command work. I can look around with the mouse and arrow-key but not use w, a, s, d, space or c.

I have to close and restart the server to be able to put down 1 more block, then it is the same again.

And when i go from prefab window to worldbuilder, i have to wait minutes before it answer.


#2

I have the same issue :frowning: tried reinstalling but it doesn’t change anything


#3

We’ve not been able to reproduce these issues so far. Was this occurring with a custom prefab, or was it any prefab and any block?


#4

Any prefab and any block for me. Even creating a brand new one results in the same auto-teleport to the edge of the prefab.

I can still manage to go up and down, and can break the blocks/glass at the bottom, but can’t physically move in any other direction


#5

I started from scratch, i build 3 blocks on top of each other, and every time i lay down a block, it started to vibrate and it disappeared…

Had to shut down the game and restart it from wb.

Edit:

After every block i laid the camera jump to -2048, 151, -2048, and lock movement.

Edit 2:

I open same world, and sometimes it work, sometimes not.

But when it work, new block still vibrate for a second or so.
Its like lag in the game, it fighting with the server about the block is there or not.


#6

What’s the performance of the main game like, compared to the World Builder?


#7

No problem with game, running smooth 99% of the time.when you place a block it look like the whole screen vibrate, like it try to find a camera position.

Another thing (or maybe the same.).

If you have a block over your head (no matter who high above) and place a block, you get teleported to that block above you.


#8

How long have you had this issue for?


#9

For me, I first noticed the placing block/teleporting issue about 3-4 updates ago, but hadn’t used world builder for some time so it could have been misbehaving for a while.


#10

I start playing with prefab yesterday (Tuesday).

Edit:
After i have shut down wb the computer are very slow, so are internet.
I have to restart the computer to get it run ok again…

I do not know if it have anything with each other to do…

I have noticed earlier that every chunk-render in wb allocate memory that it refuse to give back, so rendering in wb get slower and slower. Several time i have to close, restart and load the scene again to get memory and speed back.


#11

Were you referring to the chunk data received on the debug render information? After launching the client from the World Builder, how long was the client running before you started noticing the performance getting slower?


#12

This is another problem, i think.

1 chunk-render.

When test-render a wb-setup with the blue dot in visualisation, next to chunk,
it allocate memory, refusing to leave it back.

I see it in my resource viewer, it take a bit ram every rending, until it render so slow and ram so low i have to close wb (then i get my ram back) and restart.

2 Prefab

In prefab i experimenting an hour or two, when i closed it computer had bad performance.

As it was first time experimenting with prefab i thought i maybe started up servers that still was running, but i did not see any in the activity-list, Restarted the computer and all was ok again.


#13

i just tried to use to world builder as well. new instance, custom prefab, connected, hit the +prefab thing, launch.

i can place 1, maybe 2 blocks if im lucky. then i get launched. i can go up or down, but not any other direction.

as you can tell, my camera position in stage 1 is13.15, 129.60, 12.40

but once i place a block i get launched -28160.00, 129.60, -28160.00

i am completely unable to move in any direction except up and down.


#14

Has this happened a few times?


#15

This has happened to both me and @Heureka as well.

I have managed to get in once over the last few months, but I experienced the extreme block shaking Heureka mentions.

I’m using Windows 10 but can confirm this is also occurring on Mac as well (just tested)


#16

We’re still not seeing any of these issues. What are the specs of your machines like? Are they low, medium or high spec?


#17

cpu: intel core i7 5820k
16 gb ram

Gpu: Amd Radeon HD 7880

Windows 10, 64bit…


#18

I tried to film the shaking with Obs studio.

It shake for every block i lay, but when i played up the video it was no sign of shaking, in the video it look smooth and fine.

So probably something with the graphic on this side.


#19

Main PC:-
Windows 10 64Bit
Intel Core I7 6700K - 16GB - Z170 Motherboard
GeForce GTX 1080 FTW G/Card

Mac :-


#20

I tried prefab again, when i enter i see the floor with glasses (32*32), never seen that before.

After i place first block, i been moved away and then i can only move the camera
up and down, see video.

http://roger64.se/2017-04-07%2022-16-36.mp4