[SOLVED] Has anyone been able to get the World Builder working with Windows 10?

Like the title says, has anyone got it working? I had been working on a world for quite some time now, and while I never had any problems with World Builder on Windows 8.1, it completely refuses to run on Windows 10. I am still able to play oort, and every other game I have and I can still run every other program I have, just not the WB.

maybe @lucadeltodecso knows why. I summon you!

Or @james.

If you run the Wirld Builder from the command line are there any output messages?

When I try to launch it through steam or from the Oort online folder, the command line opens for a split second then closes. It looks like it says “Failed to initiate GLFW” or something like that. I have tried to uninstall and reinstall but I get the same thing.

OK thanks. I’ll have someone check this out tomorrow.

1 Like

We have confirmed that the World Builder works fine with Windows 10.

Our first suggestion would be to make sure you have the latest graphics drivers installed. Please confirm this.

If this still doesn’t help, please report: your graphics card and drivers.

1 Like

Updated my drivers and still nothing.

-Graphics card: AMD Radeon HD 8510G
-Driver Version: 15.200.1062.1003

It looks like you are using the latest AMD driver for the graphics card you have listed here. We have tested the World Builder on an AMD machine running Windows 10 along with driver version 15.200.1062.1003, and it works fine.

Did the World Builder previously work on Windows 10 before you upgraded the graphics driver?

No, it hasn’t worked at all for me on windows 10.

Could you try uninstalling and reinstalling Steam if that helps? We had an issue once where the game wouldn’t load on a machine, and reinstalling Steam solved the problem, so perhaps that might make a difference to the World Builder.

just reinstalled steam and the world builder still doesn’t run. it keeps giving me the same “Failed to initiate GLFW” message then closes

What is your device setup?

Do you have additional monitors connected? If so, can you try running the app with only a single display. This might help us narrow down the issue.

I can’t suggest how to further track down the issue, but I can say that we can for the next release of the world builder include more error tracking at this initialisation stage which should give more details about what is going wrong.

Well I would’ve never considered that my monitor was the problem until you mentioned it. I was thinking it was my graphics card or maybe something in my settings. When I went to check the stuff for my monitor I found that the driver for it got disabled. (Which I think happened when I upgraded to W10) So I re-enabled it and now the WB is working. I don’t know why everything else was working fine while it was disabled or why it had been disabled to begin with but it’s on now and the WB works just fine.

1 Like