[SOLVED] Request Basket Item disappeared when collecting

Hi Guys,

I had requested some Iron Ore via a request basket and when I logged on this morning, someone had sold me the 100 Ore that I requested. I then tried to drag and drop the item into my inventory and the 100 Ore just disappeared. It’s literally not in my inventory.

Have I just lost it to a bug or is there anything I can do on my end?

Thanks in advance guys. :slight_smile:

It may have stacked with any gems you have in your inventory

1 Like

Hi Prome3us,

I wish it had but all I had/have in my inventory are my tools, weapons, atlas, a few torches and some food.

Ah sorry man. Was hoping you maybe tried removing the single oortstone in the “item requested” tab instead of looking at the “purchased items” tab all the way to the right but probably not either.


Oh my. I feel so stupid now. I’m such a noob. Yea, Prome3us. That’s exactly what I was doing. I was dragging from the Item Requested and not the Purchases tab. I’m usually quick to figure these things out but maybe my old age is finally getting to me. lol.

Thanks, Prome3us. You’re a life saver. :smile: