[Solved] Weird resolution options in graphics settings caused by Windows desktop scaling %

Tags: #<Tag:0x00007fa0d0b7bec0> #<Tag:0x00007fa0d0b7bda8>

ORIGINAL TITLE: Max resolution capped at 1536x864, monitor is 1920x1080

Just loaded the game. It started in windowed mode. I opened settings, and set it to full screen.

Things didn’t look right. I soon noticed the game looked low resolution, and looked at the settings again. The “Full” resolution option was maximum 1536x864; The resolution mismatch was the cause of the graphical problem.

Updated graphics drivers for my GeForce 970, rebooted, same issue.

No resolution options in the config files I found.

Can’t find any reports of something like this, searching.

I’m stumped! Game seems very promising and chill, but it looks not as good as the YouTubes on my monitor. : (

Have you tried windowed fullscreen mode? That uses your desktop resolution.

A comment from another site which seems plausible is your Display Settings set to 125%? Which is 1980x1080 / 1.25.= 1536x864 resolution. If so we need add a check for that scaling too.

1 Like

Just tested this, with scaling at 125% my resolution is set to 1536x864 in-game.

2 Likes

We run as a boarderless window when its full screen and it does appear that the display scaling is lowering the resolution so the lower resolution is expected.

3 Likes

Solved! My Windows 10 desktop scaling WAS INDEED 125%, which affected the in-game resolution. I went back to 100%, and game looks as-expected, now.

You guys are wizards. Perfectly acceptable workaround, although it is unexpected behavior the way it works now. Unexpected, in that no other games I’ve got from the Steam interact with this Windows setting.

I do the Windows desktop scaling for accessibility purposes, so it’d be a hassle to have to switch it just to play a single game.

Thank you michaelb, willcrutchley, and OmniUno.

3 Likes

I think you can also set scaling on a per app basis - though you’ll probably have to do this every time the game is patched:

  • Find the game’s exe: C:/Program Files/Steam/steamapps/common/Boundless/boundless.exe
  • right click it -> Properties
  • and I’m pretty sure there’s a checkbox to disable resolution scaling
5 Likes

Thanks, Nevir! You’re right. Workaround further improved! Added a picture and got specific, because I now have great empathy for people who may face this issue.

  • C:/Program Files/Steam/steamapps/common/Boundless/boundless.exe
  • Right-click on boundless.exe, choose Properties from menu
  • go to Compatibility tab
  • check the box: Override high DPI scaling behavior. Scaling performed by:
  • make sure ‘Application’ is in the dropdown, but it was default for me.

7 Likes