Sovereign Guild Plotting Permission Question/Bug

Tags: #<Tag:0x00007fa0d176c928>

Hello Community and friends!

I am experiencing an issue and maybe others are experiencing this, or-- I am just somehow breaking the game.

Recently, we opened our planet to the Guild members to plot. And for everyone who was ON the planet, the permission worked, but for those who are in the guild or their alts-- I have to go back to the world control and manually add peoples permission to plot.

My question is, am I doing something wrong?

Players are maining the guild
They have been on the planet before
They have guild plotting permission turned on for the correct guild.

Is anyone else having this issue? or is Glitch… Glitched?



I’ve always been annoyed by how this works. That plotting permission is tied to a permission inside the guild. If you hover over it on your world control it will tell you. It’s not ALL people in your guild, just the ones with that permission.


I had that problem a few weeks ago on my sov.
It was the first and so far the only time it happened.

All my alts always had full perms, while citizens had limited to whatever I set them to.
Then one day I couldn’t add plots to an existing beacon of one of my alts. I soon discovered that in the world control the guild perms for guild members didn’t cover plotting and I had to manually add it then.

Still, there is a problem. I want all my alts to be able to plot on the world, but won’t necessarily want all guild members (I mean different players that are in the guild) to do so.
So I would expect the alts to be always free to do everything on my sovereigns without any permission settings. And I was pretty sure that’s how it works. You place the first beacon and world control with one of your alts. Any other alt can come over and place their own beacons as well - no permissions need to be granted through any control interface.

But then you make your guild and all your alts are members. Still, things work for months with no problem. Until what you described happens out of nowhere.
It does look like a bug to me, but I was too lazy to post about it, especially that Monumental still need time before they can engage in fixes.

1 Like

Wait… So from this I am understating I have to give guild builder perms in order to let folks claim on a Sovereign?

Guild perms to my knowledge have never affected plotting so I am confused by this.

I have it aligned under Guilds the able to go there, to gather/edit the planet and to plot via the world control, and the Plot permission are set to the blue color. I have everyone able to visit and edit-- but not everyone can plot – Yet.

I’m curious to know more of what you mean by it’s controlled by the guild.

1 Like

I also thought this was just how it worked. It sounds like guild permissions might be taking priority, and that’s definitely backwards. Especially since you don’t see your alts in your friends list, or the world control as far as I can tell.

1 Like

According to the world control, to let your entire guild plot, everyone needs worker permission. I don’t know why it works that way. I wish I could just let everyone in the guild plot, but that’s not how it works.

I think it makes an exception for people who plotted before giving that permission, but I have no idea.

1 Like

No, you don’t.
Simply the fact it always worked without even ever checking or setting it, and then suddenly the natural permissions for all world owner alts dropped, suggests it’s a bug.

1 Like

I think it just describes the hierarchy. You can’t give plotting perms without having the builder perms first. So it says that everyone with the previous tier of perms can now get the plotting as well. I didn’t test it, but just like with guild roles, clicking on the top tier perms might automatically activate previous tiers if they haven’t been given yet (so if you want someone to have all perms, you don’t have to click all perms step by step from left to right, you just click the last one and it automatically gives previous ones).

1 Like

That’s not how it works. When I got my sovereign I set it up this way, none of my guild members could plot. They couldn’t plot until I either gave it to them personally or just opened plotting to everyone, which is what I ended up doing.

I also confirmed that people with worker or above guild permission COULD plot.


just checked myself
indeed clicking the last one doesn’t automatically fill the previous

yeah - I didn’t have my guild perms set for plotting either, and the visiting and building where active from all citizens perms

my all alts could do everything of course, as I own the world

so, the weird thing was that suddenly I couldn’t add plots to one of my alt’s beacon anymore (as I expanded the build and needed to add a few plots to cover it); and after checking a few possible reasons, I discovered I can activate his plotting perms via world control by adding plotting perms to the guild members (I didn’t have to do it before, not for my alts, this guild perm was inactive)

anyways, the description part about the builders sounds weird too

1 Like

did an experiment

since that time a few weeks ago when I couldn’t plot and had to activate the guild plotting perms, the guild perms were all on

now I deactivated all guild perms
I left the world general permissions for all citizens to be able to visit and edit world

and I can do everything inside my beacons again without that guild perm on; just the way it should be and was for ages before that glitch

1 Like

From everyones input, the having “worker” permission is the required step to allow folks to plot on our planet… which sounds absolutely wrong.

“Hi you can plot on the planet and also here’s a chest controlled by the guild full of things. You can access that too.”

This sounds like there is a bug with this. I have to give folks permission to go through our storages aligned and guild controlled to be able to put a plot on the planet?

Just seems strange to me.


Yeah that guild permission thing never worked properly since sovs became a thing. We do it either with giving everyone permission or picking single people.