Testing 17 connection error

Tags: #<Tag:0x00007fa0da044070>

I’d love to test the new release but unfortunately i’m not able connecting to the game. The game stucks at “connecting to discovery server …”

i already tried to re-install the game. I’ve no “additional” firewall or proxy-settings. Testing 16 build worked without any problems for me.

@Heurazio Is this working now? It means it could not connect to the servers so it is likely a temporary connection issue.

@michaelb: No, it’s still a problem :frowning:

EDIT: Maybe the log can help you more (https://gist.github.com/anonymous/2c4c146cb89d86192e2a050cace04b90).

After a short review it seems that the discovery servers do not accapt my login (Status 401)

We should confirm that you can actually reach the server. Can you

ping -t gs-beta.playboundless.com

Assuming you can, then for some reason the server is rejecting your connection or credentials.

Can you confirm if:

  1. In any way changed your Steam account?

  2. Changed your Boundless password?

  3. If you clear your Local Content and restart the game - any difference?

There appears to be an issue with the Discovery service in Boundless. This might be triggering your issue. We’re investigating.

@james: The server seems to be reachable:

  1. No
  2. No
  3. I re-installed the game but no changes.

Hmmm. We’ll need to investigate. Looks like there is an issue with the server.

Could you quickly confirm if the “Live” version is working? (ie. Not the “Testing” version.)

It’s working perfectly.

@Heurazio We just rolled out a small fix for a server crash bug on the testing beta branch, I threw in a couple of extra logging messages so if you can try it again and share the logs again (assuming it’s still not working), and I’ll see if it shows us anything new.

@blake: https://gist.github.com/anonymous/8cfba6bd96762eb7652aa4f0395ffefc. It’s still not working.

1 Like

@Heurazio ok that confirms that the root problem is what I thought. When the game starts up we ask Steam to give us a session ticket, this is used to send to our servers when you connect to confirm you’re the player you claim to be and also allows our servers to validate the purchase of the game. For some reason when we ask Steam for that session ticket it’s failing on your machine. The reason the main live branch still works is because we’ve not reset the databases on the live branch for a while so at some point in the past it did work and in the database we’ve flagged your account as validated.

Now I’m not sure why it’s failing, I may have to push another build with lots more logging, however have you got any unusual Steam configuration for example

  • Running the Steam client betas
  • Using Steam in-home streaming (or a Steam Link)
  • Using the Steam family sharing setup
  • Running Steam in offline mode

Also do other Steam games work fine for you at the moment? Just trying to work out if there’s anything we can do to reproduce the issue ourselves?


Thanks for your explanation :slight_smile:

  1. No
  2. No
  3. No
  4. No (Friend-List is set to Offline most of the time)

I had an unusual problem with my internet explorer since the last week (that’s why i changed my default browser to Chrome) but all my usual games (Counter-Strike:GO, Factorio, The Orion Project) and all steam games i’ve played in the last week are working fine.

i’ve felt the urge i test it again (after your new patch and after a PC restart) and this time, it worked (srsly i don’t know why). I was able to play. This is the latest log from the game (https://gist.github.com/anonymous/a0a879e5cfb37d86d3765c32ef5ee127). I hope you are able to find the issue :wink:

Thanks for your help.

1 Like

Thanks for letting us know, I’m going to try and put some more logging in anyway so that if it fails again you can share up the logs and hopefully we can track down what was happening.

I think I am now getting a similar issue when attempting to log on, but some slightly different results.
Firstly, when I attempt to log on I am greeted with the login prompt. I’ve never been greeted with this screen before this problem started.

I enter my correct credentials, and the game window opens up. However, instead of taking me to the beta disclaimer screen, I get fatal error 30 and fatal error 31, and my game crashes.
I have not yet attempted a reinstallation, and I have not changed any steam settings. I have not been able to connect since the day of the world wrapping update.

You shouldn’t need to reinstall. This would only be necessary if the installation has become corrupted (unlikely) or failed to install correctly in the first place.

Can you make sure you restart Steam and try running the game again.

Could you also share a Gist of your the game log for the failed sign in.

It seems like Steams APIs aren’t as stable as we might imagine or hope. And we use these APIs to validate ownership of the game. Ideally the game would report to you that it’s Steam that is “down” rather than the game.

Yes each of the issues you describe would happen as a result of failed Steam api calls, so it definitely seems like for some reason your machine fails to initialize the Steam libraries or starts failing on Steam api calls.

If the logs don’t show anything yet I’ll add more detail to them so we can try and narrow it down.

@Havok40k how are you launching the game? If someone tries to run the boundless launcher without Steam running then they would get the behavior you’re seeing. I’m putting another error state in when we detect that so that we can catch that issue more clearly.

I was launching the game both from a desktop shortcut and from the steam launcher with the same results. Forcing steam to completely shutdown and relaunch resolved my issue, so it may simply be instabilities in steam.

Has this been resolved? I just got the game and I’m getting the same problem that you had 6 months ago… I’m starting to get a bit discouraged to see this.

If you just bought the game your account might no have been created yet, it takes a little bit for it to kick in. Once you have a title on the forum it usually means you have access to the game.