Testing 249: Repetitive failure to generate default 3 multiverse worlds

The discovery log keeps failing to initialize for the 3 worlds. Keep getting this over and over and over.

The referenced instance .jsons that seem to be failing aren’t even stored where the game thinks they are…here’s my instance folder:


Is there a way to track down what’s going on here or is my best bet to just uninstall and reinstall the game after deleting the Boundless folder in my documents?

funny how you remove the name on your second pic but above shows the same

just had a laugh moment sorry :joy: :man_shrugging:


First pic showed first and last name :blush:

Thats why my account name is BATMAN xD

Because I’m Not Batman.

1 Like

Have you edited any worldbuilder config files?
Looks like it’s trying to find a custom instance file which implies it might be a problem with some you have changed.

I’d suggest verifying your files if you haven’t already, but don’t do that until you’ve backed up any worldbuilder things you changed ofc!

But wouldn’t someone who is Batman say that

1 Like

Already did :grin:. I’ll try to find the old support thread I made later. I completely Uninstalled and reinstalled the game and the referenced .json file doesn’t exist anymore. And especially doesn’t exist as a node in any of the biomes the world config in question was trying to load.

Did the error message change? Because I think it’s possible that uninstalling and reinstalling doesn’t touch the folder in documents unless you manually delete that :thinking:

I moved the entire folder out of the documents directory and it repopulated the default configs upon reinstalling.

Also I did reinitialize the world generation without changing a thing and it froze the next time and then worked the time after.

Just added this in case the code from the red rows helps with bug squashing.


Whilst this is still in testing the fastest solution would be to delete the universe and as @willcrutchley suggested, also removing the world configs extracted into your Documents folder.

This will reset everything.

But clearly we need to make sure that the world builder is resistant to corruption of the configs.


Also defeats the purpose if your user name is an anagram of your actual name :wink:

1 Like

Sure man, but one can try. No need to fixate on it :wink:

I followed your directions here, James, a while ago. And as shown in my screenshot here, the referenced instance json doesn’t exist in the documents folder.

I’ll try to get more worlds and universes generated over the course of the day and I’ll try to keep track of how many bomb out or give errors vs. how many successes I have.

Also the cave issue in the first link of this post is still happening for me. I’ve tried multiple reinstalls but the default tier 3 cave node continues to give me problems.

Good thing I’m not Batman.