Broken Objectives


#1

Ok the number of objectives that dont work is astonishing. This should get patched ASAP:

Simple Request

It lets me complete one step the step I dont get credit for is go in a players profile and hit trade (but ths one is a know issue so Ill let it slide)

Settle in to a settlement

Dont get credit for the “acquire any beacon fuel” part when I have had plenty (the basic ones you can craft when you get your first beacon

Song of Sand and Gravel

Not getting credit for Flint despite me having 40

Onwards to Colonization

Same exact issue as Settle in to a Settlement.

Please fix these. Who knows how many else dont work. >.>


#2

The devs ask us to not make individual threads please, there is a thread dedicated to bug fixes. I suggest you post there.

These are all minor bugs, doesn’t stop you playing the game. Roll with it and move on, game is still young.


#3

Well, they do now to make seperate ones. read the last post of steggs in the release 197 bug thread :wink: … Not used to yet, but it makes sense :wink:


#4

This is a nightmare in motion. Sorry I didn’t realise they had changed it, wonder how long till they make it back into one thread.


#5

it was to complicated organizing all discussions/dialogues in one thread. May be they can hide them when finished (just visible in the support section). Also, It’s just on Patchday and the days after, so it will reduce itself over time.


#6

song of sand and gravel works fine for me as i did it like 11 hrs ago,haven’t done onwards to colonisation yet so can’t comment on that.


#7

To start off with, those are objectives rather than feats, so you may want to change the title as to avoid confusion.

Just to confirm, for the ones regarding acquiring beacon fuel, is it only occurring with basic beacon fuel, or all the beacon types?

As with the response from @Valkirth, I haven’t had any issues with the objective ‘A Song of Sand and Gravel’. What are you mining from that’s causing the game to not register the flint collected?

As far as the other comments regarding no longer having one main topic for bugs, as there’s a lot of reported issues, we felt that it’s not worthwhile creating one due to the fact that they can get very long, so it was better to have players reports bugs in separate topics so that others can add comments if they encounter similar issues.


#8

Well I found the issue. Apparently they only work if you have them pinned when you complete them… though not ALL Objectives have that requirement to work. So its still a bug but at least theyre complete-able. Tough theres now two new ones I cant complete even while Pinned;

A Less Common Coal= Travel to a world was is Rugged or more dangerous.

Did that. I had like 4 objectives that required stuff on a rugged world only 2 got completed. Even pinned the objective returned to sanctum then walked back through the portal no luck, Quit the game and logged back in after restarting it while pinned. Still nothing

Mining Survival Challenger 1 = Travel to a world that is rugged or inhospitable.

Same as above


#9

I was having trouble with Settle into a Settlement on my second character too. Broke the beacon several times, the Objective was pinned, replaced, re-selected plots, etc.

Finally worked when I replaced the beacon, did not fuel it, then put a campfire next to it of all things then it completed. Not sure what was going on there.


#10

I’m also having the issue with “Settle in to a settlement”. The objective is pinned and I have placed the beacon and added the fuel. It’s still asking me to add fuel to become part of the settlement. I’m obviously a part of the settlement because when interacting with the beacon, I’m there listed and ranked with the others but the objective still won’t complete.


#11

Put down a campfire, plot to connect to the settlement, put down a beacon, fuel the beacon. That eventually worked for me.


#12

As Splutty said, I can’t swear to it but I think the order of doing that matters. Think you can place Beacon or Campfire first ( I did Beacon then Campfire ) and I didn’t even have to put the fuel in it just registered but I suspect the problem is if you drop a beacon and fuel it your plot size isn’t large enough to be part of the settlement, there is a minimum, that’s why I started messing around with the campfire to see if I could get my plot large enough.


#13

Noob question - If I remove and re-place the beacon, will it affect the plots I’ve already put down?

I have 31 plots right now and I don’t fancy having to start over at this stage. My build is just about finished.

Thanks guys.


#14

I believe the best way to do this is craft a second beacon, place it where you want to “move” the beacon to, go into the beacon menu and set it as the master beacon, then break the original one and all should be well.

If it’s your only beacon up I don’t think it will even let you break it unless you un-claim all plots around it. Even for those things that are in the actual Beacon plot itself, if you break it they will stay they’ll just be vulnerable to other players until you get the new one up over them.


#15

Just make a new campfire and beacon, and use some leftover plots to do this step. Unless you actually want to connect your current location to a settlement, in which case, just totally ignore that step until you get to the point where you’re ready to do that.

Remember, you can have as many beacons and their associated plots as you like.