Workaround for "Settle in to a Settlement"?

This seems to still be bugged, as described in Broken Objectives, Update to testing universe - #249 by Armor11, Release 197 - Report issues here - #286 by Xardo. I get stuck on the step “Add Fuel to your Beacon Control to join the Settlement”. I’m not sure if this is because our Settlement is pretty much all Guild-aligned (one alt that hasn’t aligned yet).

Is there some specific set of steps that I need to follow for this Objective? I tried the workarounds people described using campfires and wasn’t able to get them to work, but maybe I needed to use more plots first? The idea of claiming multiple plots before fueling your new beacon is weird though, so that can’t be the intended method, right?

Do you have Gleam Club?

Nope, no gleam club.

I have understood that beacon needs to be placed away from settlement and then connect there by plotting to complete objective.
I think it would be good to attach screenshot of state of objective on this bug report.

Plot away from a town border and then plot until you joined it make sure to be a few plots away from it I’m curious to see if a towns protection plots messes this up lol

Good point, I just did so. Things I have tried:

  • Adding fuel to my beacon that’s part of the settlement
  • Removing my beacon in this settlement and re-placing it
  • Placing a new beacon 3 plots away
  • Placing a new beacon right next to the settlement, but elsewhere, not adjacent to the guild-controlled parts (one character has a home beacon there that isn’t guild-aligned yet)
  • Placing a beacon 2 plots away, not fueling it, placing a campfire in the same plot, plotting to the settlement, then fueling the beacon

Since it’s stuck on the “Add fuel” part it seems like there must be something weird about that specifically. Very frustrating! I don’t need the XP yet anyway since I want this character to be sub-20 for a bit anyway so it can craft more easily, but I’d like to resolve this so that the box is waiting for me when I’m ready. I remember having similar struggles with this objective on my other characters, too.

I’m having the same problem and it’s incredibly frustrating. I’ve tried moving away from the settlement, settling on the edges, and no dice. Has there ever been a dev response on this?

1 Like

Last time I did this, I had to make sure i was ‘touching’ the settlement along three plots along the same side…so I fueled…named…aligned to the guild (in my case don’t know if it works without aligning), added two more plots along that same settlement edge and was actually moving onto placing blocks before it dinged and caught up with me,. It’s veryyyy inconsistent though and I’ve had to reclaim and retry more often than not.


Thanks, Myst! I’ll try adding plots, I hadn’t tried that yet.

1 Like