Public Test Server Access

Hello! I have been interested in the Test Server and play on PC via Steam. Google (and other players) have provided an answer, saying that all I need to do is “opt-in” for beta in Steam settings. It is grayed out, but there IS a spot that I can enter a “beta key.” Is there any way I can get in on this or official instructions?

You just need to select the test server via properties.
Don’t forget to change it back when you want to play on the live server again.

Sometimes the test server may not be accessible.


1 Like

Yes, that is what I have tried :/. The drop-down arrow is grey and no other options. Just static on NONE. Was thinking it might be because I purchased the game more recently and my account is not provisioned or something.

Some people reported they had to try multiple times before they saw the selection. Not sure if you need to reload steam or just reopen the properties. Cant find the original thread, Try it few times, hopefully it helps.

Perhaps you have opted out of all beta programs – under Steam > Settings > Account, there’s a Beta Participation toggle. Try toggling it (the “CHANGE…” button), then (maybe after a restart) go into the Boundless settings and try again.

Hah that did it! Thank you all for your responses!

1 Like

It’s also worth mentioning that the devs often turn off the testing server between releases, but always have it up for each new release

Even that this got solved, in case someone search same problem, it could be because game is on. It is not possible to change version while game is active.


1 Like

How do you connect to those, manually via ip? All I see is no open servers and the public server cannot connect in the mmo hub

Steam > right click on Boundless > properties > Betas > testing


I have done that but I don’t see ANY servers up. So it appears that its Local hosted only.

You don’t select a server on testing, just click play. I just tried it and the servers are still up, as they have been. I’ve logged in to check events and things off and on. I’ve posted screenshots in the screenshots thread of the new weapons a couple of times.

Once you’re done you’ll have to do the steps again and deselect testing to go back into the live universe.

I can connect to the Live servers but for the Testing Branch…There are no servers/worlds to connect to:

I can connect to the testing servers every time.
Edit: I moved our convo here so we don’t derail the other thread. I assume you’ve verified your files via Steam already. Make sure you’ve exited out of the game. Maybe shut down any Steam processes in your task manager, then re-start steam.


Steam Files verified
Game exited
Boundless testing verified
Restarted Steam

Still unable to connect via the MMO option.

After you see that menu, what is the next step you are taking?

Works fine for me.

Launch Game
Wait for game to load
Hit the Go to MMO button
and stuck in Sanctum as Game Server is Offline

I didn’t start/create local universes so that option is not started on my end.

I did re-create a new character and looks like the EU Central is the only server option available now. So its working

Been thinking of going to the PTS and setting up a place, a home away from home.