Release 184 - Report issues here


#184

Sorry if already been reported as I haven’t read the whole thread!

Issue: Meteorites somehow passed through blocks. Haven’t seen the actual landing. Below are a couple of pictures of the said meteorite. To clarify, this is just one instance of meteorite with couple of pictures.

Notice the smoke on top side of the slingbow, it’s where the meteorite is below.

The said meteorite (unknowingly covered by the HP bar).

Issue: Sometimes the capital icon on the compass is not visible when overwhelmed by other icon. It would be better if it would take the highest priority when shown on the compass (i.e. always on top).

Capital not visible:
image

Capital visible (when on different angle):
image

Issue: This is a little weird. If Stout Wildstock is shot solely by Emerald Infectious Slingbow and died of the poison instead of an attack, it will not be giving experience. If it was hit with other type of slingbow but still died due to the poision, it will give experience. I’ve tried it on other mobs but this only happens on stout wildstocks. Even level 1 wildstock always gives exp.

Issue: Request basket showing 0 on both inventory items and items to sell.
image


#185

The action wheels/hot-swap wheel/quick inventory… There is one for the right hand, and one for the left hand, where one can equip a variety of items and quickly switch between them.

I guess they are more like wheels than bars in boundless, but in many similar games a linear depiction of quick-access items or abilities are arranged as bars…


#186

Hi, I would like to report an Issue with the request baskets.

Problem : I can’t set a price for the item and the request basket tab freezes. I also can’t interact with the menus anymore. I need to leave the basket tab and enter it again to be able to interact with it again, but when I click on the SET PRICE tab, the menu freezes again.

Situation : I wanted to add an item to a new request basket. I oppened the request basket, then oppened the BUDGET tab and added 1000coins. Then I oppened the SET PRICE tab, clicked on the Ink Extract, but then changed my mind because I had to look for something before. So I closed the set price box / userform without setting any price for the selected item.

Now, everytime I try to open the SET PRICE tab, in this request basket or any other request basket, it freezes. (I tried restarting the game, and didn’t work). Removing the request basket didn’t worked. Even the request basket placed long ago freezes when I try to open the SET PRICE tab.

Problematic situation:

Thank you.


#187

When baskets bug out restarting the client normally helps for you to continue working with them (not solving the problem, this is just a useful workaround).


#188

Yeah, Omni’s trick works well. This bug is not easily repeatable so i guess it’s the best way for the moment


#189

Doesn’t your screenshot show -1.188 rather than -1188?

Try as I might, I can’t seem to get to -1.188E. I can only go between -1E and -2E, but not in between.

Do you have any other examples where grass cannot be placed on those soil blocks?

Edit: Never mind, I found the area, so a bug has been logged.

However, there’s another issue here. Your screenshot displays -1.188E instead of -1,188 (in other words, a full stop / period instead of a comma). Does the GUI always display this when the coordinates display four figure numbers?

Thanks for being as in-depth as you possibly could, I’ll add this to the bug database.

This has been added to the bug database.

Thanks for the update. I’ll add it to the database anyway so that someone can see if there’s anything odd going on.

Is there any unusual data in the game log?

Doesn’t look like anyone has reported on it, so I’ll add it to the bug database.

If you see this again, can you provide some coordinates where it’s happening so that I can take a look?

Thanks for the report, I’ve added this to the bug database.

Is this occurring at a specific Request Basket? If so, what are the coordinates for its location?

Oh, you mean the radial displays. That makes sense now. I’ve not experienced this issue myself, but I’ll add the information to the database anyway.

Was this happening with any Request Baskets or specific ones?


#190

Thank you! I was not about to get to the right name.

Sorry about that. I don’t 100% know what causes it. Some changes to a Smart Stack can trigger it, but not others.

Adding another Iron Hammer to a smart stack of Iron Hammers may remove it from the radial display, but not always. A tool breaking never has this effect.

I have a smart stack of ~103 torches and 3 diamond torches. I have the 3 diamond torches from this stack equipped to a slot on my right hand, but occasionally it will be replaced with a normal torch, or removed from the radial display. I sometimes equip the normal torches to a slot on my left hand, which is basically guaranteed to make one or both not do what I expect.


#191

I dont think it ever shows fractions. Always integers.
Have never seen a fraction there. The period is there to separate thousands?


#192

Just to add… most european countries (dont know elsewhere) use a period to seperate thousands etc and a comma to seperate the fraction, so 1.888 is 1 thousand and 888 not 1 ‘point’ 888.

We do try to localise as much as we can, and we do have calls in the code to ‘localise numbers’ in most cases in the GUI (we don’t in the debug panel to keep it consistent for debugging) which should include this difference.


#193

yea it does


#194

When trying to port directly to a friend, I get the following error:

Missing portal connection WarpSrc_playerstart_other_usw_c1_home WarpDst_playerstart_17857646124294999756_other


#195

Sure I can provide one once I find the time. I guess it’s quite easy to spot though. Any capital city with lots of portals would replicate the issue. I believe the screenshot I made was from Nasharil? Or Elop…

From what I noticed, all gem request baskets at OmniShop is acting the same way.

Apologies for these uncertain answers. Will try to confirm them later.


#196

Connection is much better today so no freezes and I’ll be back on fiber tomorrow. If I do happen to freeze again I’ll be sure to share game logs.


#197

If you have connection issues please also share the standard networking details: ping test, latency test, bandwidth test, latency histogram in game and latency graph in game.


#198

Issue: Sometimes the capital icon on the compass is not visible when overwhelmed by other icon. It would be better if it would take the highest priority when shown on the compass (i.e. always on top).

I replicated the issue just now. Sometimes it got hidden by the portal icon but sometimes it just disappear randomly :\

Initial position. Capital is showing.

Walked towards left and capital icon is missing.

Walked forward and still get the same issue.

Issue: Request basket showing 0 on both inventory items and items to sell.
I’ve checked the request baskets again at OmniShop but it’s not happening anymore…


#199

Nitpicks/feedback on input (I don’t think any of these are specific to 184):

  • Single hand item switching: I don’t seem to be able to hold ctrl or alt and press number keys to switch to specific slots in the left/right hand? Was expecting that to be a thing for targeted switching

  • Hitting escape while you have text input into the chat box ends up sending your message, rather than canceling it.

  • Would be helpful to add keybinds for next/prev tab (e.g. same behavior as tapping on a controller’s bumpers)

    • Motivation: I want this for the steam controller so that I can support touch scrolling while menus are up, while still allowing the controller’s bumpers to navigate tabs - by binding all controls to keyboard/mouse when the UI is up.
    • Today, whenever you press a controller button, the mouse is hidden (makes sense), but then steam will consider the game to be in the game world at that point, not the UI
  • EXTREME EDGE CASE: The game seems to get confused about holding left stick down to run and using keyboard buttons to move; once you stop and then begin to move again it stops running

    • Motivation: I want to be able to toggle run (rather than hold to run), for RSI reasons, and the double tapping forward is also pretty painful on LS
    • Currently I’m using shift to toggle run, but it really screws up chat

#200

Thanks for providing as much information as you could. I’ll add this to the existing bug report.

It pretty much relates to what @lucadeltodecso explained above.

Can you share a game log just after you get the error again? The log should have the most recent information about what’s gone wrong.

Thanks for the update, I’ve added this to the bug database.

Let us know if you’re able to get this to occur again fairly frequently.

I’m not sure what you mean by targeted switching.

I can imagine that this will get annoying. It’s in the bug database.

This one’s for @luke-turbulenz and @olliepurkiss.

Oh, you’re using both the controller (assuming it’s still the Steam Controller) and the keyboard to move. Currently, I don’t own a Steam Controller myself to use at home, so I’ll have to wait until next week to return to the office before I can use one.


#201

I’m not sure I’ll be able to recover that :frowning: will check when I get home!

Doh sorry for confusion there!

more specifically, I’m suggesting that ctrl-5 (for example) should switch the left hand item to slot 5, etc

Yeah - I can push up my config as a community config if you want to play with it.

I’d be down with not mixing modes there too (either all in on controller, or all in on keyboard), but there’s a few things that aren’t supported on one side or the other (tabbing in windows, quick switching via sticks - which I think I can emulate with ctrl-/alt-#)


#202

Did this, after that it work smoth again :slight_smile:


#203

Having all dexterity and all attribute bonus points leads to blocks being placed double. Removing a single dexterity works around this issue.