Release 184 - Report issues here

ok, I’ll try

This may be working as intended but placing tools and such in a storage shelf or other container does not prevent the 25% durability loss on death.

Tools had been in a storage shelf for maybe 10-15 seconds before I died and all of the tools I was previously carrying still lost 25% durability. A bit unfortunate when your slingbow breaks while fighting Cuttletrunks and they follow you several hundred meters back to your base.

I can’t reproduce this one. What tools were placed into storage before you lost all health and found out that those in storage had reduced durability?

  • 1x Iron Hammer
  • 3x Iron Shovel
  • 1x Copper Grapple

I had a smart stack of Iron Shovels in my inventory, of which I had only used the first one. Upon respawning, the unused shovels showed a durability loss seemingly consistent with that from the death penalty. My hammer appeared at lowest durability possible before breaking, and copper grapple appeared at around 60% durability.

Because I feel like my previous comment was a bit muddled as to the sequence of events.

  • Meteorite fell and spawned Cuttletrunks
  • Ran back to beacon with Cuttletrunks in pursuit
  • While on low health, I quickly deposited all tools in my inventory at the time (prior to death) into a storage shelf
  • Died ~10-15 seconds after storing tools
  • Spawned back at my base
  • Checked tool durability to find that tools had received the durability death penalty

I will attempt to reproduce it later today.

the only extra information i can give you - i removed my steam friends (from the account in question - because it is an alt only account) - because that account always had the issue where i could not remove steam friends from the list… i thought removing my friends from steam itself would fix it… but the game was open when i removed them from steam… after reloading the game i was able to remove them

PLEASE NOTE - as i say… i was never allowed to remove steam friends from the list (Ever) until i removed them from steam itself and reloaded the game

After farting around with dying and tools and storage shelves for several hours, I have not been able to reproduce my issue. Surprisingly, I didn’t find any active meteorites so I was unable to test dying to Cuttletrunks but I don’t see how they could be the cause of the issue.

just had an unknown crash this game needs to cloase - we have sent a file to microsoft and then on logging back in it sent you a crash dump (as Iamme - can’t remember the official user name for that account though as i have a few name changes since :slight_smile: )

Just performed a trade and noticed that this is a reoccurring issue. The game does not properly trade my offered items to the other party and my screen freezes on the trade page after saying trade completed. The game itself does not freeze as I can see all player actions happening in the background, but any input does not work. Essentially the game transfers all of the other parties items to me but does not transfer my items to the other party. Obviously, this can be abusable if someone finds out how to replicate it.

EDIT: Maybe a second state for the trade in which the server recieves both items before delivery is not implemented?

Did it only happen once or more than once through this particular method?

Additionally, did you re-add the same friends after temporarily removing them from Steam outside of the game?

We should have the crash dump if you selected the option to send it over. Do you remember what you were doing at the time?

Were you doing anything else at the time like chatting during the trade for example?

Actually I do recall having my chat still open during it yes. I can try replicating it tomorrow.

Hi all, is it me or is this a general problem for others. I have 4 of every machine set up to craft, mixer, compactor etc. but when i use all 4 of the same type, at least two of them seem to have problems, like freeze for ages on 0 seconds before i can remove the item or not starting at all or starting quite a few minutes after i get it going. Any help or ideas to solve welcome.

1 Like

Have you tried putting one of each type of machine in a different chunk and seeing if the problem persists?

1 Like

One thing that might be placebo, but seems to help, is to open a machine that’s stuck, close it, open another machine (nearby), and then go back to the original machine

1 Like

I assume they’re repaired? Easy to miss, easy to fix with the wrench. Just a thought :slight_smile:

1 Like

Thanks for replies, yes i have ensured they are repaired, but easy to miss, lol. I have tried moving them but it makes no difference, also i would like them together or i can get muddled, (easily done for me). I have found as nevir suggests and it helps sometimes, or even going through a portal and back again works sometimes too but should this need to be the case?

1 Like

If you can provide the world and coordinates for where this issue occurring, I will then merge this thread into the main releases 184 issue reporting thread.

Also worth providing a screenshot with the debug window open and showing the Latency Graph on screen (F1 for debug tools).

1 Like

Hunch: machines go into a “passive” mode when players leave them alone for a while (so they’re not constantly running game logic). When players interact with them again, they wake up and extrapolate their progress (e.g. produces items & consumes fuel based on how long they were passive). And there’s probably a delay or race that results in machines appearing stuck when they wake back up


Is this what you need?


I was just curious if it was an issue with the number of machines in the same chunk.

1 Like

For some reason, occassionally, I seem to be getting stuck on the flowers on the ground. I would run/sprint and it would jerk me back.