Release 184 - Report issues here

yes i initiate the release myself, it hapenned to me even when i was walking on the ground, or when i was in mines and i was between two rocks, when it hapenned to me i was always holding the grapple maybe this is because i have some times bad conection to network

the issue with the screenshot (which fixed upon reload) was that remove friends was greyed out and would not let me do this, as said a reload fixed it…

concerning the Waypoint quest… i set it to my home once i was at pxle gate (maybe quater of the planet away) got home… it diod not complete… walked miles the other way… set another home waypoint a few times… did not complete… created warp blocks… set waypoint to home used warp blocks… quest completed after walking the extra step after warping…

I assume either bug, or some kind of server lag was going on at the time

@vdragon and @Touch122

I have a similar thing happen when i walk through portals (at random times so cannot reproduce that well) if i have a grapple equiped and have not used it before or after portaling, the grapple will auto fire until i click my mouse - i expect server instability causes this

I play with lag all the time. Pings are always greater than 150 on Berlyn for me, but at least I don’t see the unstable connection message as often as I would be seeing on Andooweem. As far as I know, I have only recently noticed it happening and started to test it to confirm it. Not sure if it has happened any other time.

I’m not sure if I’m doing something wrong or missing something. But I sometimes get stuck in the inventory where I can tab myself out. I have to kill the game and restart it.

have not heard this one come up in quite a few months… but i have a siilar one (since i started playing early last year) when in the inventory, (using the I button to get there) pressing I again to leave the inventory, will sometimes take you back to the profile menu - this is very rare though… another thing that is the same ehre is that when pressing esc to leave all menus… sometimes the menu will close then then instantly open up again (but i can always close it - never had to quit the game)

when trading and trying to view the other player stack:

one is the way it looks (doesnt display content)
two is I couldn’t close it or do anything else apart from using chat and breaking the trade (which I did eventually)

1# Press down Space Key and swim in water surface, the player’s character model is display as “stand” state
2# In unstable network, the player’s position and orientation in game will frequent teleportation and out-of-control due to server correction (Recursion may occur)

This is happening when I try to return to sanctum, Just showing the devs and making a thread about it :slight_smile:

1 Like

It could possibly be. I’ve added your comments to the existing bug report.

Do you remember what you were doing before the issue occurred?

Thanks for the response. There’s definitely something odd going on. I’ve checked this by creating a few different characters and pinning the objective. Some characters were able to complete the objective first time. Others were unable to complete it, so I’ve added this to the bug database.

Are you still getting the issue with items appearing to swap places between shelves and your inventory? I haven’t seen this occur so far.

Did you do anything like opening the chat function for example?

There is a known issue about GUI menus being dismissed before suddenly reappearing on screen.

It’s listed as a known issue, but we should have a fix for this in the next update.

Thanks for the report. It’s in the bug database.

Yes, this is the sort of thing that will happen when you have an unstable connection. Is it something you’re experiencing occasionally or constantly?

Thanks for the video. It’s another one of those issues where characters are being launched into the air for no reason.

Constantly(just my network problem, may not yours servers connection problem)
If the network is very unstable, game will crash after many times appearance.

I haven’t actually pushed to test it. (too painful to remember that I lost 2 stacks of gems that way) But the times it has happened its usually after making multiple jumps through different portals to get back to Berlyn. So if I am in luck sometimes I get double stacks (only happened 2x, but I have not been able to successfully duplicate it yet. Otherwise I would have flooded the market with gem tools); if I am not I loose it all. Double stacks as in 1 will be on the shelf the other in my inventory, but not very often. Starting yesterday I refrained from putting stuff on the shelf after coming out of the portal until a few mins has passed.

are servers off? cant connect to Therka or any other location within my warp distance

Im in sanctum but portals wouldnt open

EDIT: I managed to open warp to Vulpto now - Therka still not responsive

Therka should be back now.

1 Like

It probably have something to do with chat. The inventory pops up when I’m in intense fights or when I swing and run with the grapple. Also sometimes when I’m following and chatting with another player. I suspect that I somehow hit the wrong key. But when I’m in the Inventory when this happens. I just can’t get out.

After the crash occurred, did the game application terminate itself and asked for a crash dump to be submitted after you reloaded the game?

There’s probably some kind of misprediction going on, although it’s not something I’ve seen recently.

Can you check if Continuous Chat is turned on from Game Settings? If so, turn it off and see if you are able to exit the Inventory after you bring up the chat function on screen and entered a few words.

I just started today. Finished the first building missions and unlocked my core skills. Got to either level 7 or 8. Quit game. When I loaded back in everything was wiped. Level 1 again on “build a campfire.” Trying to hold my tongue on a steam review.

EDIT: Devs solved the issue. Positive review forthcoming.

  1. Boundless does not support 8 byte character (Unicode)

Steps to reproduce (on Windows 10 at least):

  1. Find a 8 bbyte character. Easiest way is to goto https://unicode-table.com/, scroll down a bit and find a character.
  2. Get the 4 digit ALT code for this character. On Unicode Table it will be the HTML-code left padded with 0 to 4 digits, so “Latin Small Letter U with Circumflex U+00FB” (which is û) has an HTML code of 251, and the ALT code is 0251. This is just a 4 digit representation of the Unicode number in decimal instead of hexidecmal.
  3. Go to a text box outside of Boundless and enter ALT+ using the right Num Pad. (ALT+0251 for the û) to verify the enters correctly in Windows
  4. Open Boundless and edit a sign, Beacon name, Settlement name, etc. and try to enter the same character (copy and paste does not work). You will get 2 random charactrs instead of the single Unicode character (û becomes û)
  1. Worlds and Settlements are zero indexed inside of “Places”

If you go to Nasharil, it is listed as a “Level 3 Developed Temperate World”, but if you go into Places -> Worlds, it is listed as “Level 2 Developed Temperate World”. Planetary Rank for settlements is the same. Settlement is listed as #12 when you walk into it, but it is #11 inside of Places -> Settlements

2 Likes

Of course, many times

If want to launch this game to Chinese Asia market, it must be solved…

We don’t have any plans to support special characters at present, but this is subject to change if the game is going to be localised into different languages.

Thanks for the report, a bug has been logged.

If you have submitted many crash dumps and log files, then we should have them.

Going back to the subject about unstable connections, what is your Chunk Download Rate and Chunk Cache Size set to in your Network Settings? Trying lowering them to see if it makes a difference.