Update: Latency Issues

We’re still investigating the latency issues that players are reporting and are very close to finding the issue. Tomorrow we’ll be confirming what we think the issue is and getting a fix ready to be sent out (possibly tomorrow). We do appreciate your patience while this is investigated.

32 Likes

2 Likes

will be interesting to see what was causing the issues, I can only imagine it’s been a bit stressful trying to sort it.

1 Like

thanks for the hard work Tiggs, Monty, and the rest of the team!

—Daax

3 Likes

The bug issue I don’t believe is latency related. I haven’t experienced it but I have seen it and has been discussed at length with people to try find out what’s causing.
Hopefully the team finds out what’s causing the issue I’m sure it’ll be resolved soon. Fingers crossed :crossed_fingers:

1 Like

20221122210004_1

Nice to see it being worked on!

3 Likes

No longer seeing the Desync issue after update but seeing some connection issues but they seem temporary as they dissipate after a small amount of time. Guess we will see.

1 Like

Not sure if this would fall under the same issue but, I’ve noticed while mining, blocks come back, but the game still counts it on your tools as Durability lost. I normally see it happen more on T7 worlds but it does happen on home worlds and Sovereign’s as well.

This is an old documented issue to do with crit hits somehow

1 Like

Now I’m having the unstable connection issue. Rubber banding, constantly placing the same block over and over, etc. After about 15 minutes, I gave up. Maybe better later or tomorrow. We’ll see…