Bug: textures in new C++ version

Newest release messed up my textures really bad. I can’t play the game without risking a serious epileptic attack, and that is bothersome to my health. I’m on a macbook pro retina (2880x1800) with a halved resolution @1440. Tried graphics settings and other resolutions, they all display this jittering crackling texture without me moving or touching a button.

I think this has to do with the per pixel lighting. When I turn it on it’s at least possible to see the flooring between all the jitters that I’m getting. And when I turn it off it becomes an extremely horrible jitter, right in my face.

This is with per pixel lighting:

This is without per pixel lighting:

I’ve been cautious with my epilepsy making the screenshots above. But you can probably imagine that the so beautifully advertised world of Boundless is not a fact for me at the moment.


Hello there. Sorry that you are experiencing this issue. Can you let me know the exact model of your Macbook, including your graphics card? Thanks

1 Like

Hello Yota,

MacBook Pro (Retina, 15-inch, Early 2013)
Processor 2,7 GHz Intel Cor i7
16 GB 1600 MHz DDR3 Memory
Intel HD Graphics 4000 1536 MB Graphics Card

Extra info:
Running OS X El Capitan 10.11.5
The graphics card is also capable of running CUDA, for which I installed the Nvidia CUDA support:

As per NVIDIA’s description:

…’ is a general purpose parallel computing architecture that leverages the parallel compute engine in NVIDIA graphics processing units (GPUs) to solve many complex computational problems in a fraction of the time required on a CPU

Thanks for getting in touch, I am happy that at least you guys are reading up on this. That gives me confidence.
Best regards,

Here’s a couple screenshots in-game with the graphics settings if you need them:


I am glad i found this thread but really sad that no resolution has been found. I too am having this problem and I am gutted I cannot play :frowning:

I understand its pre-alpha but I am just dying to get playing. If needed I can do a quick video to show the effect but basically everything is flickering like crazy

MacBook Pro (Retina, 15-inch, Early 2013)
2.8 GHz Intel Core i7
16 GB 1600 MHz DDR3
NVIDIA GeForce GT 650M 1024 MB

Let me know if i can do anything to help fix the problem, happy to run any test needed (i am also a programmer)



1 Like

We’re still working on fixing the rendering issues on OSX.


To be honest it’s a pain, because both our internal Linux and public OSX versions both use an OpenGL driver and GLSL shaders. The game works fine on Linux, and most OSX devices, however this corruption only happens on a subset of NVIDIA GPUs with OSX. We’re guessing that the game is somehow incompatible with the graphics drivers for these NVIDIA GPUs. But it’s pure voodoo working out what needs to be changed to fix it. And Apple is pretty unhelpful with resolving the issue. Unhelp = zero help.

Whilst we’re working on it - you could checkout the Legacy version via the Steam beta which I think doesn’t exhibit this issue.

Hi James,

Thanks for letting me know. I have the legacy version running now which is enough to give me my boundless fix.

Look forward to playing the new version when you get a chance to fix it.



@james I know you guys are probably breaking your brains and coffecups on this one, but I’m starting to feel the paranoidifier. Macs might be a secondary platform perhaps, but now that only a couple of macs experience this texture glitch, I feel chances are abnormally higher that we’re going to get the developer’s middlefinger eventually.

I’d like to simply ask if you could perhaps, I dunno… try and collect all of the smells from the atmospheres in the developer’s lairs, maybe sum them up and… divide by the number of developers altogether and tell the community if there’s a rather hopeless smell in there that could get my specific chipset getting dumped.

Red eyes and tears.

@endymion take a look at the unstable build (select via the steam beta chooser), there’s reports that it fixes the crazy triangles!

1 Like

It is a subset of NVIDIA based Macs that we’re having issues with. It’s the classic works everywhere else, but not here. It’s been extremely difficult for us to track down the issue(s) as we’re unable to reproduce it internally. However, we have released some development builds and had members of the community test them, these tweaks have been rolled into the latest Testing release, as @nevir posts. Definitely give it a try and report what effect it has had. We’ve not given in - sadly it seems Apple has on it’s OpenGL drivers…


Sorry for the late reply. It’s encouraging to hear that you do not give in so easily. I am going to try that beta and see if it works right away. Thank you @nevir for bringing that to my attention. Will certainly let you know how this worked out.

1 Like

Oh this is perfect!

I’ve installed the unstable test version and this is what I’m getting.
As far as I can see, no glitches. Whether or not intentionally, I love the result of the solved problem. I wish I had read about this earlier. Absolutely perfect.

Thank you @nevir and @james from the bottom of my heart.