Game Won't Launch

Just bought the game on steam. Every time I try to run the game it just says “Running” and then “Syncing” for a split second and then nothing happens. Not sure what else to do.

Check that you have the latest graphics drivers.

If you’re using avast try disabling it until game starts.

Try installing these:

1 Like

Thank you, I’ll install those and give you an update if this works out.

1 Like

Ok so I did all of those things and it’s still not launching.

1 Like

Can you share a game log? Here’s how…

1 Like

By the looks of it, it’s having trouble connecting to the Steam API

[2017-10-19 19:13:11] ERROR [FATAL ERROR] 30: Error connecting to Steam API.

Can you try restarting Steam and logging in to it again to see if that helps?

1 Like

Tried it, having the same issue, and Steam is up to date. Should I try reinstalling steam maybe?

Just realized that error is probably there because I tried running the game outside of steam directly from the local files…


Ah, yes that’ll most likely be it - it uses Steam to authenticate against

Yeah, I deleted the game log and tried running it just through steam and it doesn’t seem to create another game log.

Does it allow you to play the game now?

No, still just says “running” on the steam client for a few seconds and nothing happens.

Ok - do you have a firewall or anything out of the ordinary on your system?

Firewall is off, and I don’t think I have anything out of the ordinary that would have that effect. Unless you have something specific in mind. I play loads of other games without issue.

Could you see if the game has created any crash dumps? and if so, can you email it to the devs? Details on how to do that are in that “How do I share a Boundless game log?” link.

I’m nearing the end of what I am able to do to help, so will need to grab a dev to explore further… @james (sorry, no night off for you :wink: )

Ok so here’s something, I noticed that when I click play, the boundlessloader shows up for a few seconds in my task manager. In the turbulenz/boundlessloader_win there’s a log, maybe that would help you figure out what’s wrong?

Also there doesn’t appear to be any crash dumps.

That seems to have shed a little extra light on it - for some reason it can’t find an account associated with your Steam credentials.

How long ago did you purchase the game? It should be reasonably quick to link them

Bought the game about 3 hours ago now.

That message is basically saying its your first play. So what should then pop up is the loader that you enter your details in. If that not popping up it likely an issue with the .net framework that is uses. You can try running the .net installer by hand which should be in
C:\Program Files (x86)\Steam\SteamApps\common\boundless_CommonRedist\DotNet

As mentioned above it has to be run from Steam as it binds a Steam account to your game account.

1 Like