My character cant stop using right hand item :(


#1

Did i turned some autoclick or something? or is it a bug?
whenever i take an item in my right hand my character is using or placing it.
i restarted the game several times and restarted my computer but allways when i go back into the game and use any item in my right hand the character startes using it.

i lost 2 shiny things that i bought in market because of that when it startet because he placed that 2 blocks, well thats not that biggest problem but i cant just dont use any items in the right hand anymore like that because it is placing blocksoverall or htting anything :frowning:


[Ps4] can't move or act anymore
#2

Did you do some funky control remapping perhaps?


#3

um not that i know of, i dont changed anything in the settings so far (only the audio volume)


#4

maybe of interest seems to be the following: when i right click in an ingame ui such as the handcraft menu then the UI is kinda moving / wobbling.

It is not permament wobbling (only when i right click) so it seems like the reason for the problem is not that the game gets mouse click events.

Edit: this also is not happening in the sanctum room.


#5

I have moments like that and 2 different resons:

  1. After a poor connection moment server seems to get stuck with mouse click on - happens to both left and right hand and I need to click once more to stop it.
  2. I have had an issue with right mouse button activating itself for months now on Windows and all possible programs and apps. So, its also happens in game that when not touching mouse at all (like typing in chat) my character starts swinging his hammer or shooting sling or doing whatever action is available with right hand.

Your description doesnt seem to be one of them two at first look but who knows?


#6

If you haven’t already, I would definitely try doing a “Reset Controls to Default” from the main ESC menu.

This solved my only being able to move vertically when grappling issue.

Other than that, I can only comment that I noticed this happens to me with my left-hand equipped item (left is set as my off-hand) sometimes when I exit the Sanctum portal. i.e. If I have a grapple in my left hand it keeps grappling everything wildly, lol.

Using that item a few times or switching to another on the hotbar usually solves this for me though.


#7

Happens to me. Usually just click again or switch to a different tool.


#8

Thank you ppl for your help and your time.
seems like this is a game bug or something.

I can still play but i just cant use the right hand.

what happens and informations that i got so far:

  • i Tried to do the “Reset controls to default” tip a few times, without any success.
  • When i change the right hand to any tool or block it get used/placed
    (if i put a tool/block into the active slot ir if i rotate the slot to a tool/block)
  • I died a few times, problem still there
  • it seems like this is not happening in the sanctum room, but i dont remember if we can use the right hand at all there?
  • i Can click items in the Inventory regulary with the right mouse to see the descriptions, if i dont right click them the description is not occuring (thats why i think the game does not get any mouse click event things or something)

If you say it happend to you after a bad connection, maybe the server still “thinks” that i hold the right mouse button?
Even when i often clicked and released the RMB now alot times.

I will now go to the town and travel to portals to see if the problem also occurs on other worlds.

Edit:
I traveled to some worlds (Vulpto or something and Munten) problem also is there on that worlds to.
Maybe all that info helps to sneak a bug =)


#9

Nope, you cannot use items in the Sanctum, other than the totem the first time you choose a planetary location.

Keep us updated.


#10

Have you tried deleting gameoptions.json file in game folder? I was in trouble once long time ago after personalizing some of the default keys and that was the way to get out of it.

In case you want to try, you will find the file in Boundless>>user_settings>>“username” (files in Steam directory).


#11

I traveled to some worlds (Vulpto or something and Munten) problem also is there on that worlds to.
Maybe all that info helps to sneak a bug =)

I also endet the game, deleted all .json files in the folder as boundmore suggested. problem still there :frowning:


#12

I would also try going into steam and revarify your game files. I believe its under properties.


#13

Also, if you have any custome mouse-related software running, you might try shutting down/ending that before launching Boundless.

…getting close to being out of suggestions :confused:


#14

oki i tried to do the steam Verify thing and it said that all files are ok, problem still there :confused:
i dont use any fancy or special mouse software so far i know, also as i explained is that i can use the RMB normal in the inventory to see the description of items or something, so i dont think that there is some issue with the mouse itself (otherwise it would open the item description ist when i hover the item?)

:frowning:


#15

Last suggestions:

  1. Try a different mouse. Remove the one you have and try a different one.
  2. Try it in a different USB (or whatever) port than you currently have it plugged in to. Try another mouse in the other ports as well.

Unfortunately, after that, I think i’m about out of suggestions – this will need to be referred as a bug report and possibly take some dev attention. Sorry :frowning:


#16

this happened to me awhile back. bought a new mouse and all was well agean but I suppose you could test this by playing a difrent game and testing your right click there.


#17

True. Though it can also depend on something like the input library the devs are using. I’ve had mouse issues in certain games depending on the code/library they used for mouse/keyboard input. That certain game updated to a newer version of their input library, and poof, problem gone.

Debugging stuff like this can be a programmer’s nightmare :wink:


#18

i have this alot when im having lag but i just crazy cmick and it goes away
just metioning not very helpfull i know :smile:


#19

As i said i can use the UI / Inventory functions normal (right click to see information about an item etc)
but just to be sure i unplugged the mouse, and even without the mouse he keeps swinging the hammer.

Also if it would be a mouse issue it would affect other games or applications aswell (what is not the case).

If i go into the menu and assign both mouse buttons to the left hand, than i can use the left hand normal with both mouse buttons while the right hand keeps swinging.
(but there is no mouse button or keyboard key assigned to it)

This all feels so buggy and unlogic that i think i gonna wait for another game update for now :frowning:

Edit: i uninstalled the game via steam, deleted the whole folder of the game to get rid of any rest config or temp files.
Installed new, started the game and: problem still there.


#20

maybe we should call in the big guns.
@james do you have any thoughts on this?