Q: I'm having connection / lag issues - help!?


#61

Impossible to play. Every time I go through the Portal to Therka, it says “Slow Connection: 2000+ ms”. Has been this way for the past 12+ hours. I play in the EU server.


#62

I have exactly the same problem on Volupto, can’t play, serious lags with the mention “slow network” at the top of my screen for a little more than 48 hours now. I’ve tried to get answers here on the forum but everybody act like i’ve said nothing, very disapointed. When i use the ping application, all seems fine


#63

Please share the requested information.

Additionally what FPS does the game run at?


#64

When i’m in the starting room, i’m at 59 FPS and all is fine, as soon as i enter Volupto, it drops to 35 FPS
here you go:


#65

And the game is still reporting high latency??


#66

Well it depends, When i’m the nexus/start area. All is fine, no lags and FPS is 59. As soon as i go through the portal and on Volupto, everything goes bad: lags, FPS drops and it shows “slow network” with 600 to 1200 ms. I assume there are server issues. I’ll post you a screen shot of debug screen before and after i go through the portal.
before entering portal:

On Volupto:


#67

Can you send me a game log to checkout?

I’m not really sure what’s going on. The servers are running fine.


#68

How do i get the game log checkout?

I’ve been on Solum and it’s the same. It began the morning of the release, but there wasn’t any changes made in game. Well, i’m in canada so i don’t exactly know what time it was for you.


#69

Do you have your draw distance, foliage quality and terrain details set to full?

The sanctuary doesn’t require any long draw distances as it’s effectively an instance containing just the sanctuary itself, so it’s very light on the resource usage.

It could be that when you first walk through the portal, it’s still loading in more distant chunks - couple that with high terrain detail etc. and you can get noticeable spikes (at least I did before I upgraded my ageing graphics card).

If you leave it a short time after walking through the portal, do the slow network messages disappear and the speed improve? Alternatively, have you tried turning your graphics settings down a little to see if that helps improve things? Previously I was running my system with the following settings (and they worked quite well for me) …

Draw Distance = Grand
Terrain Detail = High
Foliage Quality = High

… or try turning those 3 down to the lowest settings and work your way up to a configuration that works for you?


#70

I’ve tried to the lowest low, It’s still the same. Updated my video driver, AMD radeon R9 200. Uninstalled and reinstalled the game.
All was fine before the update, i had played for three consecutive weeks, about 50 hours total.


#71

Hmm, very odd then…

Ok, for the game logs James requested … can you run %LOCALAPPDATA%\Turbulenz\Boundless\

There should be a boundless_log.txt with today’s date (hopefully) in there…

Just create a public gist by uploading that file into it, and then paste the URL for the gist into the forums here


#73

Here is my game log from this morning check out my transfer to Volupto around 10:38, i hope i did it allright, never used gist before:

heres another one from a bit latter, theres something not right with my inventory to, problem with stackings and splitting stacks.


#74

The more i look about it, the more i think there is something corrupted in my files. I crashed yesterday during a check run and there seems to be a problem with my player ID. If you check my game logs, there are always error messages about my player ID when i enter a world. I think this causes the lags. Yesterday, after the crash, we could see this in the game log:
[2016-12-25 00:16:49] ERROR ERROR
[2016-12-25 00:16:49] ERROR Unknown Error
[2016-12-25 00:16:51] ERROR ERROR
[2016-12-25 00:16:51] ERROR Unknown Error
[2016-12-25 00:16:51] INFO login succeeded
[2016-12-25 00:16:51] INFO got player failed (player already active on a world)
[2016-12-25 00:16:51] ERROR [ERROR] 25: Failed to retrieve player data.
[2016-12-25 00:16:51] INFO Only OK if refreshing GUI layout
[2016-12-25 00:16:51] ERROR ERROR 25
[2016-12-25 00:16:51] ERROR Failed to retrieve player data.
[2016-12-25 00:16:52] ERROR ERROR 25
[2016-12-25 00:16:52] ERROR Failed to retrieve player data.
[2016-12-25 00:16:52] INFO login succeeded
[2016-12-25 00:16:53] INFO got player failed (player already active on a world)
[2016-12-25 00:16:53] ERROR [ERROR] 25: Failed to retrieve player data.
[2016-12-25 00:16:53] INFO Only OK if refreshing GUI layout
[2016-12-25 00:16:53] ERROR ERROR 25
[2016-12-25 00:16:53] ERROR Failed to retrieve player data.


#75

For me the problem was partially solved by changing the draw distance to minimum possible. Only partially because it happens when I sprint and there is a lot of terrain information to load. I’m guessing this is because I don’t have super fast internet?


#76

Then we don’t have the same problem, changing my graphics to lowest don’t change anything beside the FPS that comes up, but lags are still the same. I hope somebody will give me feedback on my game logs. I wonder if everyone gets the warning about players entity not found when they warp to a world.


#77

Hi @DoomsdayKnight

It looks like you have a decent connection (11ms ping, 46Mbps down, 10 Mbps up, low latency to US servers, and a consistent ping).

Reducing the game to the lowest graphical settings shouldn’t really affect the latency. (In the past the game didn’t handle low fps connections terribly well but we re-implemented much of the networking to resolve this.)

In which case - it looks like the latest update has introduced an issue that has caused this. Clearly there is something in the client that is causing these large stalls.

There is nothing obvious in the client logs (or server logs) that would suggest there is a problem.

This is almost definitely a different issue - either your connection was down or something else. I would hope that if you rerun the game these issues would not reoccur.

Assuming that the original issue is in the client then we’ll only be able to investigate this once the dev team is back in the office in the new year. I appreciate this isn’t really helpful for you at the moment - but hopefully you can be patient.

I’m sure the team will have some more questions for you and may ask you to try some custom builds that include more logging.


Anyone else getting this?
#78

Additionally - can you confirm that once you’ve entered the live Worlds from the Sanctum the connection is always poor after the update. Or is it sometimes playable and sometimes bad?

Do you instantly get the bad connection warning?

Is it continuously displayed or intermittent?


#79

Thanks for the reply, i don’t mind waiting if i know my issue is assested.

1 - When i enter the Sanctum, it’s allright and i don’t have any problem, has soon as i enter a world, i have intermittent lags once every 10-20 seconds. It could be playable but very irritating
2 - When the lags occur, i get the “slow network” message at the top of the screen showing 600 to 2000 ms.
3 - it’s intermittent but consistent every 10-20 seconds. I’ts the kind of problem that will make you character jam and reapear couple of blocks away.

When the game crashed i had exactly the same lags so i figured it could be linked


#80

When you’re in the Sanctum you’re playing in an offline world running only in the client. So you will never get latency issues here.

What we need to discover is if the latency issue is:

  1. An issue of your connection - a/v, local firewall, network contention, router, firewall, local connection, route to our server, or
  2. An issue of the client - the connection is solid but the game client is causing issues.

Can you run Boundless in a Window, and at the same time open a CMD.exe window and run:

ping -t gsuse1.playboundless.com

If this reports a consistent ping even when the latency issues hit the game then it’s likely to be the client.

Let me know what happens.


#81

Here it is, the ping cmd always come clean even when i have the lags.