Release 169 - Report issues here


#204

Thanks for specifying the location. I checked many of the Request Baskets and Shop Stand here and there doesn’t seem to be anything unusual going on. Are you able to record a video showing how the issue occurs for you? Additionally, is your connection to the game generally good?


#205

There are general minor connection issues much/most of the time where I am due to the newish exchanges in our complex being overloaded almost always during peak times (which typically presents as minor packet loss or latency spikes). That said I am on 40mbps fibre so I have good connectivity whenever the exchanges allow. I also generally have 140+ms latency due to playing from South Africa.

The game has been dealing with this poorly since the new release - the basket/machine instant teleportation with a 30 second delay loss being one of those cases. If you scroll up you’ll see several other reported issues (many by me) where the new connection loss detection feature has caused issues.

This, and most other, are really easy to reproduce even with a stable connection:

  1. Open up any basket or machine, pull out your network cable for a second and plug it back in. Count to 30. Viola, back in sanctum.

EDIT: To me it feels like this is the 30 second countdown is not resetting if you have a UI open which prevents the teleportation animation from showing.

In 169 it also feels obvious that a single packet getting lost gets treated as a broken connection. From 170s notes I understand that this has since been corrected.


#206

Pulling out the cable (or disabling the network adapter), displays the ‘Game Server Connection Lost message’ for me. However, I was able to get a situation were I was getting lag when interacting with the Request Baskets and Shop Stand. The Unstable Connection appears on screen and the timer counts down, but the character is returned to the Sanctum before the timer is up. Is this similar to what you were experiencing?


#207

In my case the timer does not show, but 30 seconds after it showed the first time (just flashed) I am instantly in Sanctum. In the 30 seconds I can continue interacting with the world and it all happens (so when I go back from Sanctum no action was lost).


#208

here are the video of bug with flying over the top of a map and mini-jumps. I think this bug was caught by @Lawrey and @GrayDwarf


this is a first time i’ve catched it


I’ve start to hunt it. And i reproduced it twice, first on the slide and a second - i think it happened when i stepped on the slab(on 2:00), maybe:


#209

We may have fixed this issue on the Testing version, so it should be pushed to the Live version soon.


#210

What do you have your Chunk Download Rate and Cache Cache Size set to? Try changing the options to see if it makes a difference as discussed in the link below. You can also post about your lag issues there too.


#211

I’ve already gone through this process. I can reproduce this issue with chunk rate at minimum or maximum. My line easily deals with maximum - 40mbps uncapped handles the game with ease.

Also, I don’t generally have issues playing (I average at least 4 hours a day). I generally see lag:

  1. When interacting with things in my shop / workshop (where all chunks are loaded)
  2. Immediately after exiting a portal (regardless of my chunk rate) - already reported. If I check TCPView there I see very low traffic but dozens of TCP connections. I’m wondering if this isn’t related to latency (and some logic that keeps on opening connections for 140 or so ms).

Spelunking / hunting / exploring is generally fine.

Also, from a technical POV I doubt that this is bandwidth related. TCPView shows barely any traffic when running around my shop or portal hopping (as I visit these areas frequently and they are cached).

I do find the amount of unclosed connections when standing in my shop curious. TCPView in my shop 1 minute after loading game and entering world:

TCPView when going through portals, dozens of connections opening up to the Boundless servers coinciding with the game’s “lost connection” page/rubberbanding:


#212

@OmniUno the chunk data is downloaded over http connections, as each chunk is requested across the connection we pay a round trip latency of sending the request for the chunk and getting the response. In order to ensure the bandwidth is not idle during those latency periods we always allow multiple chunks to be downloaded in parallel. Hence we allow the client to open a number of simultaneous connections (currently limited to 32).

Opening a new http connection (rather than making a new request on an existing connection) is also much more expensive on the cpu and has a higher cost in latency time (multiple back and forth requests) as a result we allow the client to hold those connections to the server open, ready to request new chunks when they’re needed. Typically an open connection has reasonably low overhead, mostly just some reasonably small memory buffers.

The only real case where I’ve seen having many connections open is some lower end routers can struggle with many connections, although typically the “many” here is thousands rather than 50.

Out of interest when you do see lag are you seeing a corresponding drop in framerate or just lagging of movement/behavior with constant framerate? Also what sort of spec is your PC?

Oh also when you mention “interacting with things in your shop” can you give some specifics, just opening plinths, adding things, adjusting prices. If you have a video of a sequence where is does it I’d like to try and reproduce it to diagnose what’s happening.


#213

NVidia GTX960, 12GB RAM, Boundless is currently on a 1TB drive (not SSD), 3.4GHz i7. I run with everything at max, my FPS is generally between 40 and 60. I’ll keep an eye on it when I encounter issues in my shop again (can’t seem to repro it atm).

I just found the open connection count curious, it makes perfect sense for HTTP - thanks for the explanation :slight_smile:

I don’t normally record video, but I’ve set up OBS and Vimeo now - should do the job.


#214

I’m stopping to trade in gleam as the baskets keep bugging out. @cor-karolis took a screenshot showing that the color is reset to 1:


#215

I managed to reproduce the instant teleport to Sanctum after a brief disconnect on video. I can reproduce this with 100% repeatability if you want/need extra data. I did this by physically removing the LAN cable from my machine (with WiFi disabled) for just more than a second whilst on a machine’s UI.


#216

It definitely looks like the colour of the Gleam block is not matching the colour index information, so we’ve logged a bug. Just to confirm, was it definitely blue Gleam blocks you wanted to buy, or was it brown blocks (since they have colour index information of 1)?


#217

When I visited @OmniUno’s shop yesterday I tried all three of the special-color gleams – red, yellow, blue – and they were all bugged in exactly the same way:

  • the physical (I mean, non-UI-tab) appearance of the basket looked normal and showed a block of red/yellow/blue gleam
  • when I tried to sell to it, the relevant gleam in my inventory wasn’t highlighted
  • …but if I hovered on the item in my inventory it would give the price info in parentheses
  • on the “item prices” tab, all three baskets were displaying the panel in the screenshot, with the blue block image – even if the 3D basket had a red or yellow block – and “color:1”.
  • I didn’t try any cream gleam.

Edit: to clarify, these were three separate baskets that Omni had set up, for red, yellow, and blue gleams.


#218

Blue, yellow and red (in different baskets). They all seem to reset to 1 at some point based on what other players have reported.

EDIT: Saw afterwards that @cor-karolis had already answered. No new information here.


#219

A different bug with the Unstable Connection thingy: sometimes when I go through a portal it flashes the Return countdown, then immediately goes to 0 seconds but seems to get stuck there and never releases me. After 30 seconds I end up in the sanctum. Here are a handful of screens from a few different instances today:

These three are from the same occurrence, but I’m including them so you can see that the latency numbers aren’t stuck.




#220

Just to clarify, when you said that it immediately goes to zero seconds, did you mean that the timer doesn’t start from 30 seconds to begin with, but it actually displays zero as soon as the message appeared?


#221

Thanks for the video, we’ve added this information to our bug database.


#222

As I recall, it starts with the “30 seconds” but then quickly (< 1 or 2 sec) goes straight to zero. Almost like it had to display the “0 seconds” before releasing me back to normal, and then got stuck there.

This doesn’t happen every time I portal, or every time I get sanctum-timered. Usually both of those work as expected. I haven’t been able to trigger the weird kind on demand yet.


#223

I seem to have the same issue with making glue. Have the skill unlocked but crafting interface states it’s missing. Trying to make storage blocks.