Release 176 - Report issues here

Do you have a screenshot of this?

Are you using a Portal / Warp Conduit to a specific place or any place that has a roof? Can you give coordinates and / or screenshots showing where you end up versus where you should be ending up?

We should have a fix for this. In the meantime, don’t move it and make sure no one else tries to buy that item, as it will cause the disconnection issue.

Just to clarify, did you mean selling to a Request Basket? As you can only buy items from a Shop Stand, rather than a Request Basket. If you meant selling to a Request Basket, then it could be that the player who set up the basket must want blue coloured Gleam blocks will a specific colour index number.

Could you list the steps that you carried out that resulted in the situation here? This is what I did:

  1. Craft and place down a Request Basket.
  2. Interact with it and place an Igneous Rock onto it.
  3. Open the Set Price tab and select Metamorphic Rock.
  4. Set a price.
  5. Select Igneous Rock and set a price for it.
  6. Select Metamorphic Rock and remove the price.
  7. Exit the menu.

This is how I recreated the issue. Is your method different?

We’ll log a bug. Is it still not showing the complete data even after collapsing and expanding the settlement details?

Does it occur using the same method described by @ctrl-64?

If not, then please list the steps that you took to recreate this.

This is part of the ongoing GUI work, so the improvements should be a lot better.

1 Like

Hi, so I may not have test this enough. But I had slingbow crystals for sale and once someone tries to buy them it looks normal but the item cannot be bought and they receive a coin remove message but nothing actually happens. I tried putting the crystals on a different location but same thing happen.

Portals mostly, since warps I open are to middle of nowhere spots I save :smiley:
It’s mostly in places where the exit portal has been housed like a door, so there’s either a full block or sloped block directly above it. For some reason it’s just bumping me directly upwards till it finds a space the character model fits in, I believe.

I was following someone the other day, may have been @SWProzee1, and they said the same happens to them, so I’m guessing it happens randomly to many people.

Mashed up some screenies below with co-ords attached from the F1 menu. I don’t have screenshots from exactly when it happens, but it’s the same thing, bumped up to the nearest space. It doesn’t happen every time mind. Maybe it’s a lag jolt, or something loading up as I pass through.

Just toyed around with it a bit more. It looks very simple now:

Whatever item you place into the basket’s image is used - regardless of what items you set prices for. If I put in a igneous rock that’s the image I get - even if not buying igneous but sedimentary of that color.

Once a settlement shows Failed to load data it does not seem to recover. I have several that loaded succesfully now - but two failed and did not show data even when expanding/collapsing them. Going to Sanctum and back seems to fix it.

@vdragon I have clearly noticed a trend that things seem to disappear more around when I deal with the inventory and placing blocks in storage. Like I could have things equipped. Go put stuff in storage and never touch that one block. Then leave and notice my hammer (which hadn’t been touched in any way) was no longer in the wheel.

So it sounds like some of what ctrl-64 is talking about.

Only thing i can see so far is that tool have gone back in inventory some times when i come from sanctum.

It’ll happen in cases like this where the portal is “overly-framed” shall we say, whenever you aren’t careful to walk through the portal cleanly in the middle, as you’ll otherwise be attempting to spawn in the world intersecting the geometry and then get forced up.

1 Like

They look the same but have a different colour according to the game, this is consistent with rocks/trunks. However you can not buy the “same” at one request basket you need to set up two for the “same” colour gleam. Rock and trunk allow us to use one basket for multiple versions this is incosistent for gleam. One colour = one basket. Rough gems and oort are smartstackable like gleam and are buyable in one basket. Same thing different coulour?

We may have a fix for this issue once the live version is updated the next time round.

Sounds like it can happen randomly. We haven’t encounter the examples you’ve listed, but the steps listed by @ctrl-64 are reproducible however.

Thanks for explaining further. Currently, that’s the way the Request Baskets work at the moment, but I’ve pass your comments onto the designers for them to look at.

@vdragon I just had the item disappear again.

The sequence was basically moving items from one location to another –

  1. 3 hammers (grouped) in inventory.
  2. placed one in left hand, 3rd slot.
  3. hammered items and picked up various items from storage boxes until inventory was full.
  4. ran to new location (200m or so and no portals)
  5. shift left click to move all items except hammers to new storage boxes.
  6. went to repeat process and noticed that my hammer in left hand radial was removed.

I think this is the basic sequence that happens (maybe spaced over minutes, etc) that I have had happen. I do NOT shift left click much and usually just drag and drop the items. But it might be related to full inventories even though I know I’ve had it happen with not full. And I have had multiple items in my hand disappear but not all.

In any event this is at least the latest sequence I did that was very simple and resulted in the hammer removing itself from the radial.

1 Like

So I was mining when I got stuck between a very tight ceiling in Nasharil catacombs and I tried jumping to wiggle out but instead I was teleported above ground… I don’t think that’s supposed to happen XD

Shift clicking items into an iron furnace that has no empty slots causes the item to be destroyed/vanish

Cuttletrunks’ animation freezes for a second every time they fire a shot.

(I’d make a video but I’m not sure my comp could handle it)

That is great to hear and kinda what I suspected. :slight_smile:

I’ve been trying to get a video but I spent the whole crystal fighting a level 5 corrosive cuttletrunk (which was a whole other story, I was going to make another post for it) on munteen which was a very interesting battle. It was my first time seeing one of these guys and first time using a silver sling bow so I have no idea what kind of damage it was supposed to do, not only that, I put the damage crystal into it being the strongest sling bow I had (out of copper and iron, which were both more damaged) and it took all 20 shots (with a couple misses) and barely took the first bar of health… (I miss those numbers!) I paid close attention to the damage I was doing (can’t remember the exact number) and continued to hit him after the 20 shots ran out and I was doing the same damage.
The Extra Damage Crystal has no effect… unless that was intended against level 5 corrosive heh…

Ok, I just finished recording the video. Sorry there’s no audio but I demonstrated a few different bugs…

The corrosive cuttletrunk on Munteen is one of the hardest creatures in the game and the Silver tier is a mid range weapon so this is expected behaviour from a gameplay point of view.


Thanks for the information. This seems to have something to do with adding a stack of items into a smart stack, so we can look further into it.

Do you have a screenshot of what the layout looks like, together with the coordinates and the world?

Thanks for the report, we’ll log a bug.

We’re not seeing this so far. What level were the cuttletrunks affected and from what world?

  1. The first part of the video demonstrates the bug that you described previously, which was straightforward to reproduce.
  2. Afterwards, it shows that smart stacks of coal cannot be used to start the furnace properly.
  3. Three minutes into the video, I’m not sure what you’re trying to show between the slingbows.
  4. Finally, near the end of the video, it looks like you’ve lost reference to some items on the radial displays.

Is that all correct?

All levels, multiple worlds, though the low level ones don’t usually have a chance to shoot before I kill them. Most recently a lvl 4 on Munteen.

The world was Nasharil, it was in somewhere in the cuttletunk catacombs. I wouldn’t be able to find the spot even if I tried. But was like 3 block high the opening. The block on the floor were chisel like a “V” and above my head was a regular square block and next to it the block was missing. When I jump like 3 or 4 times it teleported upwards to ground level. I’ll try to go back to the area or replicate what happened.

Yes definitely smart stacks @vdragon seems to be a common factor. I just had hammer/shovel/axe in radial being show. Then went to storage, and added a few more of them to my inventory stack. Now I just noticed that all there were unassigned to radial.

There seems to be a bug when you use spark in a machine and then cancel the crafting, you sometimes get more back than it used.