Release 178 - Report issues here


#1

Please report all issues discovered in Release 178 in this thread.


Release 178: Square, Bevel and Slope Chisels!
#2

Wow request basket math is hugely broken (@OmniUno’s shop):

9 x 1 is… not 81.


#3

It looks like the number of items is being multiplied twice to generate the overall total coin that you may receive. We had a look at this and can confirm that it’s a display bug, so you were to sell these items, you would actually get 9c instead of 81c. We’ll log a bug.


#4

Phew, that’s much less terrible. Thanks :wink:

Edit: Something still wonky on the buying plinth side? I think it might be doing some weird multiplication thing here too, only this time it actually took all my moneyz :money_mouth_face:.


#5

Did you mean the Request Basket instead of Buying Plinth?


#6

Originally, yes. I confirmed that it seems like only a display bug for request baskets.

Then I went to a buying plinth and bought 2 refined diamonds, which should have been ~3800, and the display was correct, but I went from ~12000 to ~3000 coins.

Tried it with Copper Ore, no problems (5 ore, 27c, went from 3028 to 3001).

Tried it with Amethyst Torches…started with 3001, bought 2 torches for 198c total, ended up with 2061c.

Tried it again for screens, here:

Start with 2061c, buy two torches for 198c…

Displays the “198c spent” correctly, but now I only have 1269c.

Coin confirmed in inventory display:


#7

I think this needs a quick hot fix unless shops will get insurmountable loss! :sweat_smile: That’s 378,361 worth of coins for those coals.


#8

Yes, that the same issue that @cor-karolis reported above. That’s a display bug, but you will still get the correct amount.

@cor-karolis, that issue with the Shop Stands is more concerning however. I haven’t been able to reproduce it so far. Is it only happening on those Shop Stands?


#9

I’m not sure – I’ve only tried with the shop stands in @OmniUno’s place. Of those, I tried a handful: Refined Diamond, Copper Ore, Amethyst Torch. The copper worked without problems, but the others didn’t.

I think it might be related to splitting stacks? The copper had a stack of 5 ore alone, so I just bought all of it. The other two had stacks that I had to split manually with right-click.

I’d go do some more testing, but…I’m too poor :sob:

Edit @vdragon : I take it back, I’m not THAT poor. Confirmed the stack-splitting hypothesis, and also that the bug isn’t just Omni. I’ve now managed to totally screw up @Rumplypigskin’s leaf shop stand in Elop Portas. Proof:

Before:


The Stack:

I split off 2 of the 4-stack and bought them. Shoulda been 4c, display says 4c, takes 8c from inventory:

Then I bought the rest of the stack, so just the 2 remaining, no splitting:

It only took 4c from me, as it should:

However, now all of Rumply’s leaves have disappeared?!

Sorry man!

Location:


#10

Yep, definitely just a display bug. It’s hard to sell stuffs though since basket says insufficient coins.

Anyway, I’ve tried testing the buying bug that @cor-karolis mentioned. (He posted while I’m writing this up) So I would just like to add more info regarding the bug. I think the actual price deducted to my coins depends on the number of available stock. Pardon me for not having screenshot but this is what happened.

  1. Shop stand has Iron Fire Pit for 38c each.
  2. 3 pcs are available on the plinth.
  3. Bought 1 but got deducted 158c
  4. Bought another one then got deducted 77c (77/2 ~ 38.5)
  5. Iron Fire Pit is not going out of stock unlike what @cor-karolis experienced.
  6. Bought the last one and got deducted with the right price, 38c.

#11

Just going by what @cor-karolis wrote, can you confirm that the incorrect numbers are occurring due to splitting stacks?


#12

First of all, not sure if this should fall at the same bug. This wood is only selling for 1c but it’s costing me 14c.

Bought it all and got the right price.

I then bought 17 pcs of the 38 stack one (still weird as the Total Cost shows 18c)

And confirmed that pricing got skewed. It deducted 23c instead of 18.


#13

No problem. Is an easy fix for me. But I am glad my stand help show a bug!! Hope they do something about as I had a lot of bugs with shop stands since I started using them.


#14

Nooooo the console!! :sob::sob::sob::sob::scream::scream::scream::scream::scream:


#15

I have an issue when opening 2x5 portal

I can’t open it - conduits do not change to color green - neither other player could open that portal when i added them to my beacon. It doesn’t work even after rebuilding 2 portals.


#16

I’ve seen this before. I think its if you buy things from the shop stand’s “main smart stack” it unsets (some/all) of its prices.


#17

I can confirm that I actually got 8750 coins for 2 (assuming I had 5 to start with which I think is right) refined diamonds. You can come by my shop to get a refund @cor-karolis.


#18

We may have identified the issues with the Request Baskets and Shop Stands, so we’re currently looking into it.

Is the issue still persisting?


#19

a slab made with a gold bevel chis can not be modified with a sq stone or titanium chis and visa-versa


#20

I tried to open it and disconnected from the server. And now it still doesn’t work