Release 178 - Report issues here

We’ve got a notification about this, so we can look into it.

I noticed earlier that my gold bevel couldn’t bevel a wall that I’d placed before the patch. Maybe the same underlying bug, but worth noting I suppose.

I think your data confirms that you’re being charged for the whole (unsplit) stack, even when you split it.

Interesting bit is the additional charge, which is consistent with taxes internally allowing fractional coins but just using the floor when actually charging you: 13 x 1.1 is 14.3 --> 14, 17 x 1.1 = 18.7 --> 18, 38 x 1.1 = 41.8 --> 41.

(Sry, maybe everybody else already knew that!)

1 Like

We just pushed a hotfix for the request basket and shop stand.



Can confirm that shop stands seem to work from the buyer’s end, i.e. I can split a stack with right-click and only pay for the ones I want.

I still cannot split a stack in the shop stand and move it to a different slot of the stand (again as a buyer). Omni and I tried to use that as a workaround for the prices bug earlier, and it was broken then as well. It isn’t such a problem now that normal splitting works, but, you know, for your database. :wink:

No you cant alter the positions when its not yours but when buying/selling you can split it and put that in to your slots though.

Yeah, the functionality works so it’s good. Just didn’t know if I was supposed to be able to or not – I remember it worked at one point. I think. Maybe?

Just to confirm the game-breaking bug related to this:

  1. Splitting from a stack charges the buyer for the full stack but only gives him the split items (in a smart stack only the stack being split from is counted).
  2. The seller gets coin for the full stack, minus the tax the buyer paid.
    @cor-karolis and I tested this earlier and tried all combinations to verify this.

I have temporarily closed my shop as this leads to people’s coin being stolen - would be nice if you can notify us of a hotfix for this :wink:

That should be fixed. There were a number of related bugs to do with splitting stacks not working as expected in request basket/shop stand in the hot fix.

Can confirm that it is indeed fixed! Thanks for the quick hotfix :beers:

1 Like

Setting prices for request baskets are bugging out in a new way now:

This is my wood trunk basket. The first page bugs with the wrong item as usual:

But now the set price page is broken too (images missing and I cant set prices):

Minor additional issue:
Shift+click from “Purchased items” does not move to your inventory.

Seems like water can pass through solid blocks if chiseled as demonstrated below. first picture we chiseled the middle with the half slope. on the second picture we chiseled the right block into a wall, and then water started to pass through the middle block.

Not sure if already mentioned or known, but I can’t get bevelled soil to take grass. Tried only with bevel chisels on beaconed grassy soil. First hit removes grass and shapes the soil. I try to seed it afterwards but it won’t take.

Also just wondering if horizontal portals don’t work anymore? I got an error saying “portal connection portal missing” when trying to open a h4x4 portal (with 99 shards and 3 blocks of space under the conduits).

there is no bevel/square-chiselled grass, and no plans to allow it right now, as grass relies quite heavily on the texture blending for just the basic appearance of the block, and also relies on the foliage, and the foliage and texture blending either don’t work at all, or work badly, on bevel/square-chiselled blocks.


I’m not sure it’s a bug or rather by design.
When you look at the image showing all the shapes:

There a two slabs (red and green). So a bevel slab and a square slab are internally a different shape.
(And i guess pre-patch walls count as square chiseled.)

1 Like

It does look like the one exception where it should be possible to bevel / chisel a slab. We’ll add this to the database.

I suspect it may well fall under the known issue ‘Item wanted is completely different to what was placed there before on the Request Basket’ although it doesn’t seem to happen every time we tried to reproduce it. Do you remember what you were doing before the issue occurred? And does it still occur even after you have placed a trunk block onto the Request Basket to replace the leaf in the first screenshot?

Cannot reproduce this one from a Request Basket. Is it happening every time?

Thanks for the report and screenshots, a bug has been logged.

1 Like

@brook-monroe, we do have a fix for the text issue, so it should be in the next release.

1 Like

I cannot open portals either


We’re currently taking a look at this, so we should get a fix out soon.

1 Like