Release 180 - Report issues here

If in a shop, in the shop menu, use the escape-button to go to the system-menu. In the system-menu click on “go to sanctum”, then you been taken back to the shop-menu, where one more use of the escape button take you back to the game.
But 30 sec later you are transported to sanctum.

So after i clicked the go back to sanctum button it counts down without showing it, and the game continue until taken back to sanctum

Hope this sound logic…

This one is right after the crash

It started happening more often I have it like 2 times every half hour

My game crashed when i wanted to use a portal from vulpto to munteen, and i haven’t been able to log in. Game says “player already connected to a world” and if you lost your connection to wait for a few minutes. Normally this is the case but about 40 minutes is a tad over “a few minutes” now, so i am a little worried if i not managed to jump into oblivion and and am floating in some 5 dimensional space now.

Maybe its good in a few hours, but a heads up in case its not. Thanks! :slight_smile:

If it hasn’t recovered in a few minutes (say up to 15 minutes) then it is possible the character has become locked. We’ll need to manually reset it for you. If this is the case it’ll not happen until tomorrow morning (UK time). Sorry. Please let us know if it does start working.

hey there , i’ve some trouble with loading time of portal … they are sooooo long since a couple of hours… :slight_smile:

should i get skill points for hitting level 50? i didnt… i dont know if i should so im just gonna put it here… i got 10 plots. no coin or skill points.

Hello James. Thank you for your answer. I just checked, and it still doesn’t work, so you have to manually reset it. No problem with when, because i am off to work in a few. If it is working again when i get home end of the midday i am happy enough with it. :slight_smile:

Happened again on my new character creation (happened before while this version was still in testing).

Basically, I’m stuck at this selfie view after adding location to the warp and I can’t equip (cycle to it) the cube and totem to so I can’t break the warp as well. Restarting the game brought me back to choosing which server and playthrough the intro again.

Additionally, I just found out that depending on the orientation/tilt of the planet, you will not be able to see some settlement and choose it as landing site. For example, on my first try, I tried to find Chisel Knight’s settlement but failed to find it after painstakingly watch it after a full rotation. On my second try though, I’ve seen more settlement that I didn’t see before and one of them is Chisel Knight’s settlement. I just hope there will be a way to prevent this from happening?

1 Like

Should be fixed now, you managed to hit a very small timing window when you crashed causing one part of the system to think you had made it through the portal to munteen but munteen thinking you hadn’t. I’ve got it logged as a bug now so it’ll get fixed but a server restart has fixed the state and you should be able to get back on.

It works fine now. Thanks Blake! :slight_smile:

1 Like

this is strange

also on todays stream


The game is struggle to download or mesh the chunks around you, and in their place it’s using an higher LOD as a placeholder so it looks super stupid and blocky. This really shouldn’t be able to happen. I’ve seen it whilst playing the game myself. It can be triggered by moving too fast around the world, or likely by moving between intra-planet portals whilst the worlds are still loading.

Can you link me to the footage with a time stamp? I would like to share it with the team.


the whole stream

Thanks for the updated log. We’ve logged a bug so that we can look into the information that you’ve provided.

What’s the average time you’ve had to wait before portals open?

You should get skill points for reaching level 50, unless you already have the maximum available. Can you recall how many skill points you have earned up to this point?

We have fixed an issue where the camera would be stuck on certain menus, so when we push this fix live it will hopefully correct the problem you’ve encountered.

Are you saying that locations of settlements are not appearing where you expect to see them?

i have this all the time sometimes my world goes blank and i can see crosssections off the world was thinking its my pc fault not yours

Can’t reproduce this. Pressing the Esc key closes the Shop Stand menu and pressing it again opens the Main Menu for me. Selecting the option to return to the sanctum displays a message with the option to cancel as expected.

Did this occur on your own Shop Stand or someone else’s Shop Stand?

Unfortunately, I’m not familiar on where or what does chisel knight’s area looks like on the planet view. I only depended on the icons that shows on the planet while choosing and the said area is not appearing on my first try. If I’m not mistaken, the planet is tilted differently on my second try so I’m assuming it’s what caused it.

the game ran fine for about 18 hours, then it started crashing every 20 seconds or so. i reinstalled the game but it still does the same thing. anyone else experience this issue?

Did you close and reopen steam? They pushed a patch.