Release 180 - Report issues here

We pushed a small hotfix that should hopefully sort out the issue. Let us know if it still happens.

In the first screenshot, was the Gold Ore coming from the Silver Ore smart stack on the top right?

The second screenshot shows that the second smart stack is greyed out for some reason.

We may have a fix for this, which should hopefully be in the next update.

We should have a fix for this in the next update. In the meantime, as a workaround if you place the Storage Blocks in a different direction, you can use any Chisel to rotate them into the same direction as the other Storage Blocks.

We currently have this logged in the bug database.

If I understood this correctly, are you saying that the game used to cycle through every item on the radial displays but now it skips every two items? I haven’t seen this occur so far. On a different note, can you check if the number keys will select every item assigned to the radial displays?

It occur when i buy from a shopstand, after the pay i got a window saying “xx of your coin was transfered”, clicking ok in that window take me back to shop-menu.

There if i use escape-button i sometimes get to the system-menu, instead of jumping back into the game…

If i in the system-menu i click on “go to sanctum” i get back to sell-menu for the sell-plinth. Now i can press escape again to get back to game, but back to sanctum counting down and i am taken to sanctum when it reach zero. Without any countdown on the screen.

It happen in periods, sometimes 10 times without it, sometimes 3 times in row.
I have tried to find any pattern when it occur, but i do not see any.

It happen from my own sell-plints and when i buy from others.

Were you getting any noticeable lag when this happens?

Can you also check the game log for anything unusual as soon as you get the issue again?

No lag.

I check log next time i see it.

big issue with beacon rights if i add builders they can take stuff from the shopstands thats not managable if you give away alot of rights to people
it should be tier 3 to take stuff from the builds machines shops request and boxes
tier 2 build and break valuable blocks like gleam and metal blocks
tier 1 build standard blocks

1 Like

Don’t know if it’s been reported already but “Social Collaboration I-III” Feats are not working.
I finally have a collab build with 2 other characters on my beacon and it’s still (0/5).

1 Like

I understood this correctly, are you saying that the game used to cycle through every item on the radial displays but now it skips every two items? I haven’t seen this occur so far. On a different note, can you check if the number keys will select every item assigned to the radial display?

Mouse I had is broken getting new ones soon, no problem atm

This sounds like a bug. Builders should only be allowed to edit and place non-interactive blocks.

1 Like

Thanks for the report, we’ll log a bug.

I switched between my main character, Boundmore, to one of my secondary ones.
Character GUI shows the right name, level, etc.

Objectives are ok as well, however the daily xp bonus feat shows data from Boundmore character:

1 Like

Thanks for the report, a bug has been logged.

I have a stack of rocks in my inventory that I got from my other character. I’m trying to add more rocks to it from my crafting table. The stack in my inventory eats whatever rocks I’m trying to move from the crafting table. So all the rock I moved is gone.

before moving - 57 metamorphic in crafting table and a stack of 15 in my inventory:

I’m attempting to move 26 metamorphic to that stack of 15 and it briefly shows there are 41 rocks in the stack while there are 31 metamorphic left in the crafting table:

A moment later stack goes back to 15 rocks but the crafting table is still on 31 metamorphic:

EDIT: Additionally, I moved some of the metamorphic rocks to a different slot in my inventory and tried to craft warp conduits. The crafting dialog only shows the 15 rock stack and ignores the additional metamorphic. On top of that crafting doesn’t happen at all.

It’s getting more interesting. I tried to move the 15 rocks from my inventory to the crafting table for a change. And this time the stones didn’t vanish but miraculously multiplied.

I’m selecting 11 igneous rocks from the “magic” stack to add it to 46 igneous rocks I have in the crafting table:

So, briefly the 11 rocks are gone from inventory and show in the table making it 57 now:

And then they reappear in my inventory, while the table stays on 57:

I started to check what’s happening if I move the magic stack to storage blocks and then what happens to multiplied rocks in the table if I break the stack there and move to a different slot.
Weird things were happening but suddenly now everything is back to normal. All multiplied rocks are gone and the lost metamorphic rocks are back.

EDIT: Now the rocks don’t disappear or multiply but they drop back to original stack when I try to move them.
When I move more stones from table to a different slot in my inventory and try to craft warp conduits, it shows all the stones in the crafting dialogue, but it still wouldn’t craft.

EDIT 2: I moved to Sanctum and back to see if it helps and I lost the magic stack of 15 as well as other blocks (glacier, trunk) that I picked from my other character.

That’s quite a lot of information you’ve provided here. If I understood correctly, it looks like the total number of items are not being updated correctly. Did you have your mouse pointer positioned over the items at those times?

The other issue is that it looked like the items were being ‘snapped’ back to their original slots, so you were moving items from your Inventory to the Crafting Table, but then they reappear back into the Inventory. Is that also right? (Edit: did you experience any lag during those moments?)

The total number of items was indeed not correct (either less or more than it should be).

I only started positioning mouse over items for screenshots, after I noticed something weird had been happening. Originally I hadn’t been doing that.

Yes, in case when I was gaining extra rocks, the blocks I was moving appeared in the stack I was moving them to, but were also snapped back to the stack I was taken them from.
In case when I was losing rocks, the blocks I was moving disappeared from the stack I was taking them from, but didn’t add up to the stack I was moving them to.
In both cases there was a moment it worked correctly. Moved rocks were gone from where I took them from and they briefly appeared where I moved them to. Also numbers briefly updated as they should. Only after that second or so it would go off.

No lags or rubber banding experienced during described actions. Not beyond my average (these days I have short bad connection moments every few minutes and occasional lags when I’m doing something fast like mining or placing blocks).

Although we were not able to get the exact same results, we did experience the situation where items would sometimes snap back to their original locations between the inventory and storage for example. Nevertheless, we’ll log a bug.

Here’s a thing that have been bothering me… most of the times when you are going to chisel away a side with a bevel chisel it sometimes refuses when you try to chisel a diagonal side.

It appears it is affected by which direction the diagonal is pointing at. This is probably true for some other diagonal shapes (like when you use the gold chisel)

2 Likes

Another chisel bug is that if you already chiseled a part of the back of the block, the game seems to look for the last face it can find that belongs to the block you are chiseling.

This is a square-chiseled block, when using the chisel again from this angle, you might get unexpected results depending on if you hit the next face of the geometry.

2 Likes

error 4001 “illegal protocol message”

After selling some items on several plinths, I attempted to move oort stone between slots in my inventory. And I got that.