Release 182 - Report issues here


#41

Ugggh. Thanks for letting us know.

(How many am I up to? Take 10.) Sorry x10.


#42

Tax is still on the same bug as before, even though world says " Tax: 10%"
Explanation:

Guy A : Selling a hammer at 100c
Guy B : Sees the hammer on stand at 110c

if guy B gets the -10% tax skill, guy B will see 109c
and it only applies when Guy B buys from Guy A and no other case, not even baskets

Skill states: “Reduces the amount of tax you pay for items sold by 10%”

it doesn’t specify if :
1.*sold by you on anothers basket
2.*sold by you on a stand to others

but the fact is that the reduced tax applies when you BUY, not when you sell.


#43

The point isn’t to be better than a torch, it’s just mean to allow you to free up a hand. I think it’s meant to be worse @jefalaska


#44

I think it’s supposed to be equivalent - as you say - to free up a hand.

We did attempt to make the held and placed lights more consistent. But we’ve clearly not checked the result on the self light skills.

I would imaging it’ll be fairly easy to fix. Expect it patched in the next day (or so).


#45

If it helps at all, this didn’t happen when my miner leveled today. However, she is under level 20.


#46

I don’t see the point of freeing up a hand in the caves, personally. Maybe if you’re building in a dark place. The only thing I’ve ever needed in the depths of the earth are my hammers and occasionally a shovel. Easy enough to rotate between. I see that this might change, however, should they plan to have enemies spawn in the cave depths as well as the surface. Then it would be handy to have a slingbow in the other hand.


#47

It comes in handy when you are grapple hooked to the ceiling and mining.


#48

As @Havok40k said, having light, a grapple, and a hammer is very handy. I find freeing up a hand invaluble when mining for gems in vulpto, say.


#49

I can imagine, but I’ve never gotten the grapple to work. I just hang at the end like a fly trapped in a spider’s web until I release it. I guess you have to invest skills to get that to work right as well?


#50

Just to say @james, I dont know whether you ever fixed it, but that storage bug @TwistedFoot pointed out is still here (the Natural Crystal one) except it works with lava and water buckets too:


#51

Are you using the controls to reel yourself and let yourself out? R and F respectively. Grapple mastery improves the projectile speed of the grapple, and maybe some other things like the reel in speed.


#52

Searching google indicated that space and shift were used, but when that failed I tried every button on my keyboard, with no success. Thank you for informing me of the proper keys :slight_smile: . I’ll make a new one and try again with these.


#53

Sale store problems now. I put a grapple in one of my stores, attempting to sell it to my miner, but it will not allow me to set a price. when I hit the price tab, there are no options available, and the store freezes, not letting me interact with any other buttons (takings or stock). Hitting escape exits out of the shop stand. Just to make sure, I tried selling a hammer as well. This one appeared in the prices tab, but again would not allow me to set a price or shift to another tab. Not sure if it is significant or not, but the hammer was stone and undamaged, the grapple was iron and had been used a few times.


#54

This doesn’t fix the glitch, but you should be able to add alts to your beacon and share storage


#55

I cannot reproduce this. Have you tried removing and placing the plinth again?

Update - Oh! I think I can. You place an item for sale with a price, then you remove that item from the shops inventory, put the item back and go to set the price - no price option. Nice find!

@vdragon


#56

This is more about how clearly this information is shown on the stands and baskets.

The reduction does work for the seller in both cases.

If you are selling items in a stand there will be tax reduction if you have the skill
If you are selling items to a basket there will be a tax reduction if you have the skill

However! You need to place the items up for sale again after you’ve unlocked the skill. It is not automatically applied to items on sale.

We need to do more about informing players about the tax and how it is applied to items.


#57

Removing a placing the stand again did not fix the bug, and it seems to affect all three stands. It was fixed after I quit and reloaded the game. I too was able to reproduce it after removing and then re-adding an item.


#58

At least we got a solid repro for it.

My trick to get it working again was to move the item into the slot of the plinth, close the menu, open it again and I had the options to set the price.


#59

This is more of an unintended side effect of the lighting changes. We’ll address it.


#60

This doesn’t seem to work for me. Just to be sure I’m doing it correctly, after the stand it bugged, you leave the item in the plinth, exit the store interface, then re-enter the interface and set a price? Doing this leaves me in the same state as before, unable to set a price or navigate between tabs. Removing the item from the plinth, replacing it, exiting then re-entering the store also fails, as does removing the item, exiting, re-entering, re-adding, and various other combinations of the same. Did I miss a step?